# 500 Server error

**URL:** <https://discourse.chef.io/t/500-server-error/1672>\
**Category:** Chef Infra (archive)\
**Created:** [January 5, 2011, 5:54pm UTC](https://discourse.chef.io/t/500-server-error/1672 "2011-01-05T17:54:24Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![Tristan\_Sloughter](https://sea2.discourse-cdn.com/flex016/user_avatar/discourse.chef.io/tristan_sloughter/32/819_2.png) [@Tristan\_Sloughter](https://discourse.chef.io/u/Tristan_Sloughter)\
**Post date:** [January 5, 2011, 5:54pm UTC](https://discourse.chef.io/t/500-server-error/1672/1 "2011-01-05T17:54:24Z")

</div>

I was having a problem where I had updated a template file (I verified  
through the web interface that the template file was updated) but when the  
client was run on a client it would not get the new version. Trying to force  
it to I ended up delete /var/cache/chef/checksums/ on the server… This  
seems to have been very bad.

When I realized this had borked the cookbook I did a bulk delete and purge  
of that cookbook. I then ran the upload command on it again. This doesn’t  
seem to really be doing anything. It doesn’t output checksums of all files  
that its uploading like usual, it just displays the messages of the steps  
and acts like it ran fine. I delete the checksums in ~/.chef/checksums just  
in case but still nothing.

So now when I run the client on a node with -l debug I get lots of:

[Wed, 05 Jan 2011 11:44:53 -0600] DEBUG:  
/cookbooks/ecdmarket/0.0.1/files/40e78bbf6e012c82eaefebd7292faeb3 (zero  
content length or no Content-Length header)

And then a 500 error.

Which I assume is due to the upload not working correctly.

Does anyone have any ideas?

Thanks,  
Tristan

---

<div class="post-metadata">

**Author:** ![kallistec](https://sea2.discourse-cdn.com/flex016/user_avatar/discourse.chef.io/kallistec/32/23_2.png) [@kallistec](https://discourse.chef.io/u/kallistec)\
**Post date:** [January 5, 2011, 6:13pm UTC](https://discourse.chef.io/t/500-server-error/1672/2 "2011-01-05T18:13:22Z")

</div>

On Wed, Jan 5, 2011 at 9:54 AM, Tristan Sloughter  
[tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com) wrote:

> I was having a problem where I had updated a template file (I verified  
> through the web interface that the template file was updated) but when the  
> client was run on a client it would not get the new version. Trying to force  
> it to I ended up delete /var/cache/chef/checksums/ on the server... This  
> seems to have been very bad.  
> When I realized this had borked the cookbook I did a bulk delete and purge  
> of that cookbook. I then ran the upload command on it again. This doesn't  
> seem to really be doing anything. It doesn't output checksums of all files  
> that its uploading like usual, it just displays the messages of the steps  
> and acts like it ran fine. I delete the checksums in ~/.chef/checksums just  
> in case but still nothing.

What version of Chef do you have on the server? The `--purge` option  
was not implemented until 0.9.10 and, unfortunately, I made a mistake  
when I implemented it so it's not quite usable yet (the fix is merged  
in master, but not yet in a released version). These bugs are tracked  
as CHEF-1364[0] and CHEF-1836[1].

What you're seeing is that the database has checksum objects that are  
supposed to correspond to files on disk (in that checksums directory)  
but the files have been deleted. The easiest way to get back to a good  
state is to delete the checksum documents from the database. To do  
that, you need to log in to your chef-server box, then run `shef`.  
From shef, run the following code to delete the checksum documents:

```
require 'chef/checksum'
r = Chef::REST.new('http://localhost:5984/chef/_design/checksums/_view/',

```

false, false)  
r.get\_rest("all")["rows"].each {|c| c["value"].cdb\_destroy}

After that, upload all of your cookbooks again and you should be good to go.

Dan DeLeo

1. [http://tickets.opscode.com/browse/CHEF-1364](http://tickets.opscode.com/browse/CHEF-1364)
2. [http://tickets.opscode.com/browse/CHEF-1836](http://tickets.opscode.com/browse/CHEF-1836)

> So now when I run the client on a node with -l debug I get lots of:  
> [Wed, 05 Jan 2011 11:44:53 -0600] DEBUG:  
> /cookbooks/ecdmarket/0.0.1/files/40e78bbf6e012c82eaefebd7292faeb3 (zero  
> content length or no Content-Length header)  
> And then a 500 error.  
> Which I assume is due to the upload not working correctly.  
> Does anyone have any ideas?  
> Thanks,  
> Tristan

---

<div class="post-metadata">

**Author:** ![Tristan\_Sloughter](https://sea2.discourse-cdn.com/flex016/user_avatar/discourse.chef.io/tristan_sloughter/32/819_2.png) [@Tristan\_Sloughter](https://discourse.chef.io/u/Tristan_Sloughter)\
**Post date:** [January 5, 2011, 6:21pm UTC](https://discourse.chef.io/t/500-server-error/1672/3 "2011-01-05T18:21:20Z")

</div>

Ah, yeah, I'm running 0.9.8. I should probably update, I think the problem I  
had with the template not updating on the client is fixed in a later version  
as well.

Great, that worked! Everything is working again.

But... the template still isn't being used on the client. This is really  
pretty nuts, hehe. I just added '-smp enable' to the template and I see  
clearly its in the template by going to the web interface and viewing it in  
the cookbook but when I look at the file it is saved as on the clients that  
piece isn't there...

I'd rather not have to get things updated to a newer Chef to fix this unless  
its the quickest/easier way.

Tristan

On Wed, Jan 5, 2011 at 12:13 PM, Daniel DeLeo [dan@kallistec.com](mailto:dan@kallistec.com) wrote:

> On Wed, Jan 5, 2011 at 9:54 AM, Tristan Sloughter  
> [tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com) wrote:
> 
> > I was having a problem where I had updated a template file (I verified  
> > through the web interface that the template file was updated) but when  
> > the  
> > client was run on a client it would not get the new version. Trying to  
> > force  
> > it to I ended up delete /var/cache/chef/checksums/ on the server... This  
> > seems to have been very bad.  
> > When I realized this had borked the cookbook I did a bulk delete and  
> > purge  
> > of that cookbook. I then ran the upload command on it again. This doesn't  
> > seem to really be doing anything. It doesn't output checksums of all  
> > files  
> > that its uploading like usual, it just displays the messages of the steps  
> > and acts like it ran fine. I delete the checksums in ~/.chef/checksums  
> > just  
> > in case but still nothing.
> 
> What version of Chef do you have on the server? The `--purge` option  
> was not implemented until 0.9.10 and, unfortunately, I made a mistake  
> when I implemented it so it's not quite usable yet (the fix is merged  
> in master, but not yet in a released version). These bugs are tracked  
> as CHEF-1364[0] and CHEF-1836[1].
> 
> What you're seeing is that the database has checksum objects that are  
> supposed to correspond to files on disk (in that checksums directory)  
> but the files have been deleted. The easiest way to get back to a good  
> state is to delete the checksum documents from the database. To do  
> that, you need to log in to your chef-server box, then run `shef`.  
> From shef, run the following code to delete the checksum documents:
> 
> require 'chef/checksum'  
> r = Chef::REST.new('[http://localhost:5984/chef/\_design/checksums/\_view/](http://localhost:5984/chef/_design/checksums/_view/)  
> ',  
> false, false)  
> r.get\_rest("all")["rows"].each {|c| c["value"].cdb\_destroy}
> 
> After that, upload all of your cookbooks again and you should be good to  
> go.
> 
> Dan DeLeo
> 
> 1. [http://tickets.opscode.com/browse/CHEF-1364](http://tickets.opscode.com/browse/CHEF-1364)
> 2. [http://tickets.opscode.com/browse/CHEF-1836](http://tickets.opscode.com/browse/CHEF-1836)
> 
> > So now when I run the client on a node with -l debug I get lots of:  
> > [Wed, 05 Jan 2011 11:44:53 -0600] DEBUG:  
> > /cookbooks/ecdmarket/0.0.1/files/40e78bbf6e012c82eaefebd7292faeb3 (zero  
> > content length or no Content-Length header)  
> > And then a 500 error.  
> > Which I assume is due to the upload not working correctly.  
> > Does anyone have any ideas?  
> > Thanks,  
> > Tristan

---

<div class="post-metadata">

**Author:** ![Bryan\_McLellan](https://sea2.discourse-cdn.com/flex016/user_avatar/discourse.chef.io/bryan_mclellan/32/81_2.png) [@Bryan\_McLellan](https://discourse.chef.io/u/Bryan_McLellan)\
**Post date:** [January 5, 2011, 6:29pm UTC](https://discourse.chef.io/t/500-server-error/1672/4 "2011-01-05T18:29:59Z")

</div>

On Wed, Jan 5, 2011 at 10:21 AM, Tristan Sloughter  
[tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com) wrote:

> Ah, yeah, I'm running 0.9.8. I should probably update, I think the problem I  
> had with the template not updating on the client is fixed in a later version  
> as well.

There were some issues with early cookbook version implementations in  
0.9.8 [1][2][3]. Reading through those bugs may help you figure out  
how to get that cookbook to load.

btm

[1] [http://tickets.opscode.com/browse/CHEF-1607](http://tickets.opscode.com/browse/CHEF-1607)  
[2] [http://tickets.opscode.com/browse/CHEF-1571](http://tickets.opscode.com/browse/CHEF-1571)  
[3] [http://tickets.opscode.com/browse/CHEF-1747](http://tickets.opscode.com/browse/CHEF-1747)

---

<div class="post-metadata">

**Author:** ![Tristan\_Sloughter](https://sea2.discourse-cdn.com/flex016/user_avatar/discourse.chef.io/tristan_sloughter/32/819_2.png) [@Tristan\_Sloughter](https://discourse.chef.io/u/Tristan_Sloughter)\
**Post date:** [January 5, 2011, 6:38pm UTC](https://discourse.chef.io/t/500-server-error/1672/5 "2011-01-05T18:38:12Z")

</div>

Thanks. It seems the latest version of Chef in the EPEL repos is 0.9.8, is  
this true? Is there another repo to use for centos that is updated more  
often?

On Wed, Jan 5, 2011 at 12:29 PM, Bryan McLellan [btm@loftninjas.org](mailto:btm@loftninjas.org) wrote:

> On Wed, Jan 5, 2011 at 10:21 AM, Tristan Sloughter  
> [tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com) wrote:
> 
> > Ah, yeah, I'm running 0.9.8. I should probably update, I think the  
> > problem I  
> > had with the template not updating on the client is fixed in a later  
> > version  
> > as well.
> 
> There were some issues with early cookbook version implementations in  
> 0.9.8 [1][2][3]. Reading through those bugs may help you figure out  
> how to get that cookbook to load.
> 
> btm
> 
> [1] [http://tickets.opscode.com/browse/CHEF-1607](http://tickets.opscode.com/browse/CHEF-1607)  
> [2] [http://tickets.opscode.com/browse/CHEF-1571](http://tickets.opscode.com/browse/CHEF-1571)  
> [3] [http://tickets.opscode.com/browse/CHEF-1747](http://tickets.opscode.com/browse/CHEF-1747)

---

<div class="post-metadata">

**Author:** ![Sean\_OMeara](https://sea2.discourse-cdn.com/flex016/user_avatar/discourse.chef.io/sean_omeara/32/435_2.png) [@Sean\_OMeara](https://discourse.chef.io/u/Sean_OMeara)\
**Post date:** [January 5, 2011, 6:43pm UTC](https://discourse.chef.io/t/500-server-error/1672/6 "2011-01-05T18:43:59Z")

</div>

Unfortunately no, not currently.

Centos5 has a lot of old libraries that make it a real pain to keep up with.

I plan to provide bundler-ized RPMs for Centos6 (once it comes out)

They are currently available for fedora13 here:  
[http://yum.afistfulofservers.net/affs-chef/fedora/13/x86\_64/](http://yum.afistfulofservers.net/affs-chef/fedora/13/x86_64/)

-s

On Wed, Jan 5, 2011 at 1:38 PM, Tristan Sloughter  
[tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com) wrote:

> Thanks. It seems the latest version of Chef in the EPEL repos is 0.9.8, is  
> this true? Is there another repo to use for centos that is updated more  
> often?  
> On Wed, Jan 5, 2011 at 12:29 PM, Bryan McLellan [btm@loftninjas.org](mailto:btm@loftninjas.org) wrote:
> 
> > On Wed, Jan 5, 2011 at 10:21 AM, Tristan Sloughter  
> > [tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com) wrote:
> > 
> > > Ah, yeah, I'm running 0.9.8. I should probably update, I think the  
> > > problem I  
> > > had with the template not updating on the client is fixed in a later  
> > > version  
> > > as well.
> > 
> > There were some issues with early cookbook version implementations in  
> > 0.9.8 [1][2][3]. Reading through those bugs may help you figure out  
> > how to get that cookbook to load.
> > 
> > btm
> > 
> > [1] [http://tickets.opscode.com/browse/CHEF-1607](http://tickets.opscode.com/browse/CHEF-1607)  
> > [2] [http://tickets.opscode.com/browse/CHEF-1571](http://tickets.opscode.com/browse/CHEF-1571)  
> > [3] [http://tickets.opscode.com/browse/CHEF-1747](http://tickets.opscode.com/browse/CHEF-1747)

---

<div class="post-metadata">

**Author:** ![Tristan\_Sloughter](https://sea2.discourse-cdn.com/flex016/user_avatar/discourse.chef.io/tristan_sloughter/32/819_2.png) [@Tristan\_Sloughter](https://discourse.chef.io/u/Tristan_Sloughter)\
**Post date:** [January 5, 2011, 7:33pm UTC](https://discourse.chef.io/t/500-server-error/1672/7 "2011-01-05T19:33:36Z")

</div>

Thanks, Sean.

Man, this is not a good day for me and Chef. Now I'm suddenly getting this  
new 500 error when I run the chef client as well as if I do a knife cookbook  
upload when it gets to the INFO: Uploading files. Very weird is I see the  
files (recipes and templates) when I go to the web interface.

[Wed, 05 Jan 2011 13:31:15 -0600] DEBUG: Sending HTTP Request via PUT to  
10.36.34.41:4000/nodes/ecduat02vm01  
[Wed, 05 Jan 2011 13:31:18 -0600] WARN: HTTP Request Returned 500 Internal  
Server Error: Connection failed - user: chef  
/usr/lib/ruby/1.8/net/http.rb:2097:in `error!': 500 "Internal Server Error" (Net::HTTPFatalError) from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/rest.rb:229:in `api\_request'  
from  
/usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/rest.rb:280:in  
`retriable_rest_request' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/rest.rb:210:in `api\_request'  
from  
/usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/rest.rb:126:in  
`put_rest' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/node.rb:502:in `save'  
from  
/usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/client.rb:175:in  
`build_node' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/client.rb:75:in `run'  
from  
/usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/application/client.rb:212:in  
`run_application' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/application/client.rb:202:in `loop'  
from  
/usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/application/client.rb:202:in  
`run_application' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/application.rb:62:in `run'  
from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/chef-client:26  
from /usr/bin/chef-client:19:in `load'  
from /usr/bin/chef-client:19

On Wed, Jan 5, 2011 at 12:43 PM, Sean OMeara [someara@gmail.com](mailto:someara@gmail.com) wrote:

> Unfortunately no, not currently.
> 
> Centos5 has a lot of old libraries that make it a real pain to keep up  
> with.
> 
> I plan to provide bundler-ized RPMs for Centos6 (once it comes out)
> 
> They are currently available for fedora13 here:  
> [http://yum.afistfulofservers.net/affs-chef/fedora/13/x86\_64/](http://yum.afistfulofservers.net/affs-chef/fedora/13/x86_64/)
> 
> -s
> 
> On Wed, Jan 5, 2011 at 1:38 PM, Tristan Sloughter  
> [tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com) wrote:
> 
> > Thanks. It seems the latest version of Chef in the EPEL repos is 0.9.8,  
> > is  
> > this true? Is there another repo to use for centos that is updated more  
> > often?  
> > On Wed, Jan 5, 2011 at 12:29 PM, Bryan McLellan [btm@loftninjas.org](mailto:btm@loftninjas.org)  
> > wrote:
> > 
> > > On Wed, Jan 5, 2011 at 10:21 AM, Tristan Sloughter  
> > > [tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com) wrote:
> > > 
> > > > Ah, yeah, I'm running 0.9.8. I should probably update, I think the  
> > > > problem I  
> > > > had with the template not updating on the client is fixed in a later  
> > > > version  
> > > > as well.
> > > 
> > > There were some issues with early cookbook version implementations in  
> > > 0.9.8 [1][2][3]. Reading through those bugs may help you figure out  
> > > how to get that cookbook to load.
> > > 
> > > btm
> > > 
> > > [1] [http://tickets.opscode.com/browse/CHEF-1607](http://tickets.opscode.com/browse/CHEF-1607)  
> > > [2] [http://tickets.opscode.com/browse/CHEF-1571](http://tickets.opscode.com/browse/CHEF-1571)  
> > > [3] [http://tickets.opscode.com/browse/CHEF-1747](http://tickets.opscode.com/browse/CHEF-1747)

---

<div class="post-metadata">

**Author:** ![Sean\_OMeara](https://sea2.discourse-cdn.com/flex016/user_avatar/discourse.chef.io/sean_omeara/32/435_2.png) [@Sean\_OMeara](https://discourse.chef.io/u/Sean_OMeara)\
**Post date:** [January 5, 2011, 7:37pm UTC](https://discourse.chef.io/t/500-server-error/1672/8 "2011-01-05T19:37:13Z")

</div>

Jump on freenode #Chef Infra (archive)

On Wed, Jan 5, 2011 at 2:33 PM, Tristan Sloughter  
[tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com) wrote:

> Thanks, Sean.  
> Man, this is not a good day for me and Chef. Now I'm suddenly getting this  
> new 500 error when I run the chef client as well as if I do a knife cookbook  
> upload when it gets to the INFO: Uploading files. Very weird is I see the  
> files (recipes and templates) when I go to the web interface.  
> [Wed, 05 Jan 2011 13:31:15 -0600] DEBUG: Sending HTTP Request via PUT to  
> 10.36.34.41:4000/nodes/ecduat02vm01  
> [Wed, 05 Jan 2011 13:31:18 -0600] WARN: HTTP Request Returned 500 Internal  
> Server Error: Connection failed - user: chef  
> /usr/lib/ruby/1.8/net/http.rb:2097:in `error!': 500 "Internal Server Error" (Net::HTTPFatalError) from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/rest.rb:229:in `api\_request'  
> from  
> /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/rest.rb:280:in  
> `retriable_rest_request' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/rest.rb:210:in `api\_request'  
> from  
> /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/rest.rb:126:in  
> `put_rest' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/node.rb:502:in `save'  
> from  
> /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/client.rb:175:in  
> `build_node' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/client.rb:75:in `run'  
> from  
> /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/application/client.rb:212:in  
> `run_application' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/application/client.rb:202:in `loop'  
> from  
> /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/application/client.rb:202:in  
> `run_application' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/application.rb:62:in `run'  
> from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/chef-client:26  
> from /usr/bin/chef-client:19:in `load'  
> from /usr/bin/chef-client:19  
> On Wed, Jan 5, 2011 at 12:43 PM, Sean OMeara [someara@gmail.com](mailto:someara@gmail.com) wrote:
> 
> > Unfortunately no, not currently.
> > 
> > Centos5 has a lot of old libraries that make it a real pain to keep up  
> > with.
> > 
> > I plan to provide bundler-ized RPMs for Centos6 (once it comes out)
> > 
> > They are currently available for fedora13 here:  
> > [http://yum.afistfulofservers.net/affs-chef/fedora/13/x86\_64/](http://yum.afistfulofservers.net/affs-chef/fedora/13/x86_64/)
> > 
> > -s
> > 
> > On Wed, Jan 5, 2011 at 1:38 PM, Tristan Sloughter  
> > [tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com) wrote:
> > 
> > > Thanks. It seems the latest version of Chef in the EPEL repos is 0.9.8,  
> > > is  
> > > this true? Is there another repo to use for centos that is updated more  
> > > often?  
> > > On Wed, Jan 5, 2011 at 12:29 PM, Bryan McLellan [btm@loftninjas.org](mailto:btm@loftninjas.org)  
> > > wrote:
> > > 
> > > > On Wed, Jan 5, 2011 at 10:21 AM, Tristan Sloughter  
> > > > [tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com) wrote:
> > > > 
> > > > > Ah, yeah, I'm running 0.9.8. I should probably update, I think the  
> > > > > problem I  
> > > > > had with the template not updating on the client is fixed in a later  
> > > > > version  
> > > > > as well.
> > > > 
> > > > There were some issues with early cookbook version implementations in  
> > > > 0.9.8 [1][2][3]. Reading through those bugs may help you figure out  
> > > > how to get that cookbook to load.
> > > > 
> > > > btm
> > > > 
> > > > [1] [http://tickets.opscode.com/browse/CHEF-1607](http://tickets.opscode.com/browse/CHEF-1607)  
> > > > [2] [http://tickets.opscode.com/browse/CHEF-1571](http://tickets.opscode.com/browse/CHEF-1571)  
> > > > [3] [http://tickets.opscode.com/browse/CHEF-1747](http://tickets.opscode.com/browse/CHEF-1747)

---

<div class="post-metadata">

**Author:** ![Tristan\_Sloughter](https://sea2.discourse-cdn.com/flex016/user_avatar/discourse.chef.io/tristan_sloughter/32/819_2.png) [@Tristan\_Sloughter](https://discourse.chef.io/u/Tristan_Sloughter)\
**Post date:** [January 5, 2011, 8:12pm UTC](https://discourse.chef.io/t/500-server-error/1672/9 "2011-01-05T20:12:06Z")

</div>

Thanks, I also posted that I found the solution in the irc channel. I found  
it on

[http://ruxable.com/2010/10/chef-server-connection-failed-to-rabbitmq-using-bunny-protocol-as-user-chef/](http://ruxable.com/2010/10/chef-server-connection-failed-to-rabbitmq-using-bunny-protocol-as-user-chef/)

But I also had to give the amqp password to the add\_user command.

Really weird that after running update this happened..

Thanks,  
Tristan

On Wed, Jan 5, 2011 at 1:37 PM, Sean OMeara [someara@gmail.com](mailto:someara@gmail.com) wrote:

> Jump on freenode #Chef Infra (archive)
> 
> On Wed, Jan 5, 2011 at 2:33 PM, Tristan Sloughter  
> [tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com) wrote:
> 
> > Thanks, Sean.  
> > Man, this is not a good day for me and Chef. Now I'm suddenly getting  
> > this  
> > new 500 error when I run the chef client as well as if I do a knife  
> > cookbook  
> > upload when it gets to the INFO: Uploading files. Very weird is I see the  
> > files (recipes and templates) when I go to the web interface.  
> > [Wed, 05 Jan 2011 13:31:15 -0600] DEBUG: Sending HTTP Request via PUT to  
> > 10.36.34.41:4000/nodes/ecduat02vm01  
> > [Wed, 05 Jan 2011 13:31:18 -0600] WARN: HTTP Request Returned 500  
> > Internal  
> > Server Error: Connection failed - user: chef  
> > /usr/lib/ruby/1.8/net/http.rb:2097:in `error!': 500 "Internal Server Error" (Net::HTTPFatalError) from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/rest.rb:229:in `api\_request'  
> > from  
> > /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/rest.rb:280:in  
> > `retriable_rest_request' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/rest.rb:210:in `api\_request'  
> > from  
> > /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/rest.rb:126:in  
> > `put_rest' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/node.rb:502:in `save'  
> > from  
> > /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/client.rb:175:in  
> > `build_node' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/client.rb:75:in `run'  
> > from
> 
> /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/application/client.rb:212:in
> 
> > `run\_application'  
> > from
> 
> /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/application/client.rb:202:in
> 
> > `loop'  
> > from
> 
> /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/application/client.rb:202:in
> 
> > `run\_application'  
> > from
> 
> /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/application.rb:62:in
> 
> > `run' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/chef-client:26 from /usr/bin/chef-client:19:in `load'  
> > from /usr/bin/chef-client:19  
> > On Wed, Jan 5, 2011 at 12:43 PM, Sean OMeara [someara@gmail.com](mailto:someara@gmail.com) wrote:
> > 
> > > Unfortunately no, not currently.
> > > 
> > > Centos5 has a lot of old libraries that make it a real pain to keep up  
> > > with.
> > > 
> > > I plan to provide bundler-ized RPMs for Centos6 (once it comes out)
> > > 
> > > They are currently available for fedora13 here:  
> > > [http://yum.afistfulofservers.net/affs-chef/fedora/13/x86\_64/](http://yum.afistfulofservers.net/affs-chef/fedora/13/x86_64/)
> > > 
> > > -s
> > > 
> > > On Wed, Jan 5, 2011 at 1:38 PM, Tristan Sloughter  
> > > [tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com) wrote:
> > > 
> > > > Thanks. It seems the latest version of Chef in the EPEL repos is  
> > > > 0.9.8,  
> > > > is  
> > > > this true? Is there another repo to use for centos that is updated  
> > > > more  
> > > > often?  
> > > > On Wed, Jan 5, 2011 at 12:29 PM, Bryan McLellan [btm@loftninjas.org](mailto:btm@loftninjas.org)  
> > > > wrote:
> > > > 
> > > > > On Wed, Jan 5, 2011 at 10:21 AM, Tristan Sloughter  
> > > > > [tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com) wrote:
> > > > > 
> > > > > > Ah, yeah, I'm running 0.9.8. I should probably update, I think the  
> > > > > > problem I  
> > > > > > had with the template not updating on the client is fixed in a  
> > > > > > later  
> > > > > > version  
> > > > > > as well.
> > > > > 
> > > > > There were some issues with early cookbook version implementations in  
> > > > > 0.9.8 [1][2][3]. Reading through those bugs may help you figure out  
> > > > > how to get that cookbook to load.
> > > > > 
> > > > > btm
> > > > > 
> > > > > [1] [http://tickets.opscode.com/browse/CHEF-1607](http://tickets.opscode.com/browse/CHEF-1607)  
> > > > > [2] [http://tickets.opscode.com/browse/CHEF-1571](http://tickets.opscode.com/browse/CHEF-1571)  
> > > > > [3] [http://tickets.opscode.com/browse/CHEF-1747](http://tickets.opscode.com/browse/CHEF-1747)

---

<div class="post-metadata">

**Author:** ![Paul\_Choi](https://avatars.discourse-cdn.com/v4/letter/p/43a26b/32.png) [@Paul\_Choi](https://discourse.chef.io/u/Paul_Choi)\
**Post date:** [January 7, 2011, 7:30pm UTC](https://discourse.chef.io/t/500-server-error/1672/10 "2011-01-07T19:30:38Z")

</div>

If you used EPEL and ELFF repos to update your Chef-related RPMs, updating RabbitMQ will wipe your existing rabbitmq configs. It's not too bad… Just need to add\_vhost /chef, add\_user, set permissions on it.

Initially I thought it happened because RabbitMQ was updated from v1 to v2.0, but it's also happening when you upgrade from one version of RabbitMQ v2 to the next.

-Paul

From: Tristan Sloughter \<[tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com)[mailto:tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com)\>  
Reply-To: "[chef@lists.opscode.com](mailto:chef@lists.opscode.com)[mailto:chef@lists.opscode.com](mailto:chef@lists.opscode.com)" \<[chef@lists.opscode.com](mailto:chef@lists.opscode.com)[mailto:chef@lists.opscode.com](mailto:chef@lists.opscode.com)\>  
Date: Wed, 5 Jan 2011 14:12:06 -0600  
To: "[chef@lists.opscode.com](mailto:chef@lists.opscode.com)[mailto:chef@lists.opscode.com](mailto:chef@lists.opscode.com)" \<[chef@lists.opscode.com](mailto:chef@lists.opscode.com)[mailto:chef@lists.opscode.com](mailto:chef@lists.opscode.com)\>  
Subject: [chef] Re: Re: Re: Re: Re: Re: Re: Re: 500 Server error

Thanks, I also posted that I found the solution in the irc channel. I found it on

[http://ruxable.com/2010/10/chef-server-connection-failed-to-rabbitmq-using-bunny-protocol-as-user-chef/](http://ruxable.com/2010/10/chef-server-connection-failed-to-rabbitmq-using-bunny-protocol-as-user-chef/)

But I also had to give the amqp password to the add\_user command.

Really weird that after running update this happened..

Thanks,  
Tristan

On Wed, Jan 5, 2011 at 1:37 PM, Sean OMeara \<[someara@gmail.com](mailto:someara@gmail.com)[mailto:someara@gmail.com](mailto:someara@gmail.com)\> wrote:  
Jump on freenode #Chef Infra (archive)

On Wed, Jan 5, 2011 at 2:33 PM, Tristan Sloughter  
\<[tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com)[mailto:tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com)\> wrote:

> Thanks, Sean.  
> Man, this is not a good day for me and Chef. Now I'm suddenly getting this  
> new 500 error when I run the chef client as well as if I do a knife cookbook  
> upload when it gets to the INFO: Uploading files. Very weird is I see the  
> files (recipes and templates) when I go to the web interface.  
> [Wed, 05 Jan 2011 13:31:15 -0600] DEBUG: Sending HTTP Request via PUT to  
> 10.36.34.41:4000/nodes/ecduat02vm01[http://10.36.34.41:4000/nodes/ecduat02vm01](http://10.36.34.41:4000/nodes/ecduat02vm01)  
> [Wed, 05 Jan 2011 13:31:18 -0600] WARN: HTTP Request Returned 500 Internal  
> Server Error: Connection failed - user: chef  
> /usr/lib/ruby/1.8/net/http.rb:2097:in `error!': 500 "Internal Server Error" (Net::HTTPFatalError) from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/rest.rb:229:in `api\_request'  
> from  
> /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/rest.rb:280:in  
> `retriable_rest_request' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/rest.rb:210:in `api\_request'  
> from  
> /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/rest.rb:126:in  
> `put_rest' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/node.rb:502:in `save'  
> from  
> /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/client.rb:175:in  
> `build_node' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/client.rb:75:in `run'  
> from  
> /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/application/client.rb:212:in  
> `run_application' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/application/client.rb:202:in `loop'  
> from  
> /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/application/client.rb:202:in  
> `run_application' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/../lib/chef/application.rb:62:in `run'  
> from /usr/lib/ruby/gems/1.8/gems/chef-0.9.8/bin/chef-client:26  
> from /usr/bin/chef-client:19:in `load'  
> from /usr/bin/chef-client:19  
> On Wed, Jan 5, 2011 at 12:43 PM, Sean OMeara \<[someara@gmail.com](mailto:someara@gmail.com)[mailto:someara@gmail.com](mailto:someara@gmail.com)\> wrote:
> 
> > Unfortunately no, not currently.
> > 
> > Centos5 has a lot of old libraries that make it a real pain to keep up  
> > with.
> > 
> > I plan to provide bundler-ized RPMs for Centos6 (once it comes out)
> > 
> > They are currently available for fedora13 here:  
> > [http://yum.afistfulofservers.net/affs-chef/fedora/13/x86\_64/](http://yum.afistfulofservers.net/affs-chef/fedora/13/x86_64/)
> > 
> > -s
> > 
> > On Wed, Jan 5, 2011 at 1:38 PM, Tristan Sloughter  
> > \<[tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com)[mailto:tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com)\> wrote:
> > 
> > > Thanks. It seems the latest version of Chef in the EPEL repos is 0.9.8,  
> > > is  
> > > this true? Is there another repo to use for centos that is updated more  
> > > often?  
> > > On Wed, Jan 5, 2011 at 12:29 PM, Bryan McLellan \<[btm@loftninjas.org](mailto:btm@loftninjas.org)[mailto:btm@loftninjas.org](mailto:btm@loftninjas.org)\>  
> > > wrote:
> > > 
> > > > On Wed, Jan 5, 2011 at 10:21 AM, Tristan Sloughter  
> > > > \<[tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com)[mailto:tristan.sloughter@gmail.com](mailto:tristan.sloughter@gmail.com)\> wrote:
> > > > 
> > > > > Ah, yeah, I'm running 0.9.8. I should probably update, I think the  
> > > > > problem I  
> > > > > had with the template not updating on the client is fixed in a later  
> > > > > version  
> > > > > as well.
> > > > 
> > > > There were some issues with early cookbook version implementations in  
> > > > 0.9.8 [1][2][3]. Reading through those bugs may help you figure out  
> > > > how to get that cookbook to load.
> > > > 
> > > > btm
> > > > 
> > > > [1] [http://tickets.opscode.com/browse/CHEF-1607](http://tickets.opscode.com/browse/CHEF-1607)  
> > > > [2] [http://tickets.opscode.com/browse/CHEF-1571](http://tickets.opscode.com/browse/CHEF-1571)  
> > > > [3] [http://tickets.opscode.com/browse/CHEF-1747](http://tickets.opscode.com/browse/CHEF-1747)
