Chef 0.10.10 Released


#1

We’ve released Chef 0.10.10.

You can read the release notes here:


Bryan McLellan | opscode | technical program manager, open source
© 206.607.7108 | (t) @btmspox | (b) http://blog.loftninjas.org


#2

On Saturday, May 12, 2012 at 24:10 , Bryan McLellan wrote:

We’ve released Chef 0.10.10.

You can read the release notes here:
http://www.opscode.com/blog/2012/05/11/chef-0-10-10-released/

Hi,

Thank you very much for everyone’s hard work.

I maintain RPM packages for RHEL (and derivatives) 5 and 6 over at http://pakk.96b.it/ and I see that some gem dependencies have been changed for the 0.10.10 release. I don’t mind packaging mixlib-shellout (although I would prefer to wait for a non RC release), but there is now a problem with yajl-ruby.

The ‘chef’ gem now requires version ‘>= 1.1.0’ and the ‘chef-exander’ gem requires version ‘~> 0.7.7’ (which means ‘<= 0.7.9’), as before. Could the dependency for ‘chef-expander’ be updated or is there really an incompatibility with newer versions?

I know that the way forward is to use the Omnibus installer, but I would like to keep using my packages.


Eric-Olivier Lamey


#3

On 05/12/2012 09:54 PM, Eric-Olivier Lamey wrote:

On Saturday, May 12, 2012 at 24:10 , Bryan McLellan wrote:

We’ve released Chef 0.10.10.

You can read the release notes here:
http://www.opscode.com/blog/2012/05/11/chef-0-10-10-released/

Hi,

Thank you very much for everyone’s hard work.

I maintain RPM packages for RHEL (and derivatives) 5 and 6 over at
http://pakk.96b.it/ and I see that some gem dependencies have been
changed for the 0.10.10 release. I don’t mind packaging
mixlib-shellout (although I would prefer to wait for a non RC
release), but there is now a problem with yajl-ruby.

The ‘chef’ gem now requires version ‘>= 1.1.0’ and the 'chef-exander’
gem requires version ‘~> 0.7.7’ (which means ‘<= 0.7.9’), as before.
Could the dependency for ‘chef-expander’ be updated or is there really
an incompatibility with newer versions?
You can use 1.1.0 with chef-expander.

Alan


#4

On Sat, May 12, 2012 at 7:54 AM, Eric-Olivier Lamey eolamey@gmail.com wrote:

I maintain RPM packages for RHEL (and derivatives) 5 and 6 over at
http://pakk.96b.it/ and I see that some gem dependencies have been changed
for the 0.10.10 release. I don’t mind packaging mixlib-shellout (although I
would prefer to wait for a non RC release), but there is now a problem with
yajl-ruby.

You can package the mixlib-shellout 1.0 release. That’s what I did for
the debian packaging. The requirement on the RC is a bug that we
didn’t catch before release.

Bryan


#5

On Sunday, May 13, 2012 at 16:52 , Alan Milligan wrote:

The ‘chef’ gem now requires version ‘>= 1.1.0’ and the ‘chef-exander’ gem requires version ‘~> 0.7.7’ (which means ‘<= 0.7.9’), as before. Could the dependency for ‘chef-expander’ be updated or is there really an incompatibility with newer versions?

You can use 1.1.0 with chef-expander.

Hi Alan,

Thank you very much for your answer, that’s great news!


Eric-Olivier


#6

On Sunday, May 13, 2012 at 17:09 , Bryan McLellan wrote:

You can package the mixlib-shellout 1.0 release. That’s what I did for
the debian packaging. The requirement on the RC is a bug that we
didn’t catch before release.

Hi Bryan,

Thank you, I noticed the 1.0.0 release on rubygems.org after having sent my message, I already packaged it.


Eric-Olivier