Chef Development Kit 0.2.1


#1

Hey folks,

Today we’ve released Chef DK 0.2.1. The big news for this release is “Mac
OS X 10.8” support.

You can read more about the release here:

Check it out and let us know if you run into any issues.

– Serdar


#2

The HTTPS download link from that post seems to have the wrong cert:

https://downloads.getchef.com/chef-dk

It has a cert for *.cloudfront.net instead.

Douglas William Thrift
http://douglasthrift.net/

On 8/28/2014 2:08 PM, Serdar Sutay wrote:

Hey folks,

Today we’ve released Chef DK 0.2.1. The big news for this release is
"Mac OS X 10.8" support.

You can read more about the release here:

http://www.getchef.com/blog/2014/08/28/release-chef-development-kit-0-2-1/

Check it out and let us know if you run into any issues.

– Serdar


#3

+1 seeing the same.

depth=2 C = US, O = “VeriSign, Inc.”, OU = VeriSign Trust Network, OU
= “© 2006 VeriSign, Inc. - For authorized use only”, CN = VeriSign
Class 3 Public Primary Certification Authority - G5
verify error:num=20:unable to get local issuer certificate
verify return:0
subject=/C=US/ST=Washington/L=Seattle/O=Amazon.com Inc./CN=*.cloudfront.net

–aj

On Fri, Aug 29, 2014 at 9:28 AM, Douglas Thrift douglaswth@gmail.com wrote:

The HTTPS download link from that post seems to have the wrong cert:

https://downloads.getchef.com/chef-dk

It has a cert for *.cloudfront.net instead.

Douglas William Thrift
http://douglasthrift.net/

On 8/28/2014 2:08 PM, Serdar Sutay wrote:

Hey folks,

Today we’ve released Chef DK 0.2.1. The big news for this release is
"Mac OS X 10.8" support.

You can read more about the release here:

http://www.getchef.com/blog/2014/08/28/release-chef-development-kit-0-2-1/

Check it out and let us know if you run into any issues.

– Serdar


#4

Hello Chefs,
can somebody tell me why this started appearing with a simple “Knife cookbook upload”?
/usr/local/var/rbenv/versions/1.9.3-p448/lib/ruby/gems/1.9.1/gems/ffi-yajl-1.1.0/lib/ffi_yajl/ext.rb:51: Use RbConfig instead of obsolete and deprecated Config.
/usr/local/var/rbenv/versions/1.9.3-p448/lib/ruby/gems/1.9.1/gems/chef-11.14.6/lib/chef/knife/core/subcommand_loader.rb:34:in `load’: cannot load such file – /Users/luisf.flores/.chef/plugins/knife/gesystem_secret_remove_key.rb (LoadError)

What has happened to the “simple” to use chef?

Luis Fernando Flores
+52 449 9107800 xt: 6241
Av. Eugenio Garza Sada #902
Parque Industrial Tecnopolo
Aguascalientes, Aguascalientes,
Mexico 20328

On Aug 28, 2014, at 4:08 PM, Serdar Sutay <serdar@getchef.commailto:serdar@getchef.com> wrote:

Hey folks,

Today we’ve released Chef DK 0.2.1. The big news for this release is “Mac OS X 10.8” support.

You can read more about the release here:

Check it out and let us know if you run into any issues.

– Serdar


#5

Did you remove (or not readd) your gesystem_secret_remove_key.rb?

On Friday, August 29, 2014 at 8:46 AM, Flores, Luis Fernando (GE Capital, Non-GE) wrote:

Hello Chefs,
can somebody tell me why this started appearing with a simple “Knife cookbook upload”?
/usr/local/var/rbenv/versions/1.9.3-p448/lib/ruby/gems/1.9.1/gems/ffi-yajl-1.1.0/lib/ffi_yajl/ext.rb:51: Use RbConfig instead of obsolete and deprecated Config.
/usr/local/var/rbenv/versions/1.9.3-p448/lib/ruby/gems/1.9.1/gems/chef-11.14.6/lib/chef/knife/core/subcommand_loader.rb:34:in `load’: cannot load such file – /Users/luisf.flores/.chef/plugins/knife/gesystem_secret_remove_key.rb (LoadError)

What has happened to the “simple” to use chef?

Luis Fernando Flores
+52 449 9107800 xt: 6241
Av. Eugenio Garza Sada #902
Parque Industrial Tecnopolo
Aguascalientes, Aguascalientes,
Mexico 20328

On Aug 28, 2014, at 4:08 PM, Serdar Sutay <serdar@getchef.commailto:serdar@getchef.com> wrote:

Hey folks,

Today we’ve released Chef DK 0.2.1. The big news for this release is “Mac OS X 10.8” support.

You can read more about the release here:

http://www.getchef.com/blog/2014/08/28/release-chef-development-kit-0-2-1/

Check it out and let us know if you run into any issues.

– Serdar


#6

On Friday, August 29, 2014 at 8:48 AM, Daniel Condomitti wrote:

Did you remove (or not readd) your gesystem_secret_remove_key.rb?

On Friday, August 29, 2014 at 8:46 AM, Flores, Luis Fernando (GE Capital, Non-GE) wrote:

Hello Chefs,
can somebody tell me why this started appearing with a simple “Knife cookbook upload”?
/usr/local/var/rbenv/versions/1.9.3-p448/lib/ruby/gems/1.9.1/gems/ffi-yajl-1.1.0/lib/ffi_yajl/ext.rb:51: Use RbConfig instead of obsolete and deprecated Config.
/usr/local/var/rbenv/versions/1.9.3-p448/lib/ruby/gems/1.9.1/gems/chef-11.14.6/lib/chef/knife/core/subcommand_loader.rb:34:in `load’: cannot load such file – /Users/luisf.flores/.chef/plugins/knife/gesystem_secret_remove_key.rb (LoadError)

What has happened to the “simple” to use chef?

Luis Fernando Flores
I see a couple of issues here. One, it looks like you’re using a local rbenv install instead of ChefDK (unless your email was not a comment about ChefDK 0.2.1 — if that’s the case, please remember to start a new thread in the future, since it’s confusing when the subject and content are unrelated).

The warning about Use RbConfig instead of obsolete and deprecated Config you can ignore. For what it’s worth, it occurs in some fallback code that should only be activated if you have built ruby —without-fiddle.

As for the “real” error, cannot load such file -- /Users/luisf.flores/.chef/plugins/knife/gesystem_secret_remove_key.rb (LoadError), knife has scanned that directory for .rb files then attempts to load them. It’s possible that the permissions are simply wrong on that file.


Daniel DeLeo


#7

I think this is another group’s matter, sorry Daniel and thank you for your reply.

Luis Fernando Flores
+52 449 9107800 xt: 6241
Av. Eugenio Garza Sada #902
Parque Industrial Tecnopolo
Aguascalientes, Aguascalientes,
Mexico 20328

On Aug 29, 2014, at 10:48 AM, Daniel Condomitti <daniel@condomitti.commailto:daniel@condomitti.com>
wrote:

Did you remove (or not readd) your gesystem_secret_remove_key.rb?

On Friday, August 29, 2014 at 8:46 AM, Flores, Luis Fernando (GE Capital, Non-GE) wrote:

Hello Chefs,
can somebody tell me why this started appearing with a simple “Knife cookbook upload”?
/usr/local/var/rbenv/versions/1.9.3-p448/lib/ruby/gems/1.9.1/gems/ffi-yajl-1.1.0/lib/ffi_yajl/ext.rb:51: Use RbConfig instead of obsolete and deprecated Config.
/usr/local/var/rbenv/versions/1.9.3-p448/lib/ruby/gems/1.9.1/gems/chef-11.14.6/lib/chef/knife/core/subcommand_loader.rb:34:in `load’: cannot load such file – /Users/luisf.flores/.chef/plugins/knife/gesystem_secret_remove_key.rb (LoadError)

What has happened to the “simple” to use chef?

Luis Fernando Flores
+52 449 9107800 xt: 6241
Av. Eugenio Garza Sada #902
Parque Industrial Tecnopolo
Aguascalientes, Aguascalientes,
Mexico 20328

On Aug 28, 2014, at 4:08 PM, Serdar Sutay <serdar@getchef.commailto:serdar@getchef.commailto:serdar@getchef.com> wrote:

Hey folks,

Today we’ve released Chef DK 0.2.1. The big news for this release is “Mac OS X 10.8” support.

You can read more about the release here:

Check it out and let us know if you run into any issues.

– Serdar