Chef-server with non-standard port?


#1

Since a new version of Chef Server 12.6.0 was just announced, I was wondering about the bug that it does not work with a non-standard HTTPS port.

The issue is on github as #50 https://github.com/chef/chef-server/issues/50 - there was a PR for a fix six months ago (thanks!), but I haven’t seen it appear in the actual released chef servers yet.


#2

The best way to deal with Chef-Server I have found so far is encapsulating it in a Docker Container. 3ofcoins has a very nice example for this: https://github.com/3ofcoins/docker-chef-server/.
This may not be a solution for you if your are not working with docker but it definitely is worth a look.


#3

Q: Can I run this on another port, like most HTTP services?
A: Have you tried Docker?

:slowclap:


#4

My question was actually about the status of that bug report; it has been in a black hole for almost two years now.

That said, I am actually working with Docker, but in this case I needed the Chef server to run on the same IP address as a standard Web server, so port 443 is simply unavailable.

Chef theoretically supports using an alternate port, but that feature has been broken for a long time. With every new Chef release, I have to re-apply the patch to fix it.

Kevin Keane
Whom the IT Pros Call
The NetTech
http://www.4nettech.com
Our values: Privacy, Liberty, Justice
See https://www.4nettech.com/corp/the-nettech-values.html