Chef Vcloud 404 error


#1

I downloaded vcloud plugin from the URL
https://github.com/astratto/knife-vcloud and i setup the configuration using

knife vc configure command

and entered the details below:

URL - 'https://1.1.1.1/abc/cloud/org/abc-lab/'
username - 'karthik’
Password - abc

where ‘abc-lab’ is the organization name in the vcloud environment. Once the
configuration file is created, I gave the following command,

knife vc org list

and it returned 404 resource not found error. Any help appreciated.


#2

The url you have configured in your example could be too deep.
Usually you only have to specify vcloud director fqdn listening on https
port, without any web-context.
In order to verify the correct url, you should try to list supported api
versions from your vcloud director installation (you should receive an xml
answer):
https://yourvcloud.server.url/api/versions

For previous example what has to be configured for knife-vcloud is just:
yourvcloud.server.url

You can try the configuration with:
knife vc login

If previous command gives a positive answer please read carefully
knife-vcloud Readme for what concerns vcloud login configuration, IDs and
names and verify what kind of account you are using:

  • when a vcloud OU administrator, you have to specify --org-login parameter
  • when a vcloud system administrator, you have to specify --org parameter
    (see “Browse multiple organizations”)

Hope this helps.
Greetings,
Marco
I downloaded vcloud plugin from the URL
https://github.com/astratto/knife-vcloud and i setup the configuration using

knife vc configure command

and entered the details below:

URL - 'https://1.1.1.1/abc/cloud/org/abc-lab/'
username - 'karthik’
Password - abc

where ‘abc-lab’ is the organization name in the vcloud environment. Once the
configuration file is created, I gave the following command,

knife vc org list

and it returned 404 resource not found error. Any help appreciated.


#3

Hi Marco,

Thanks for the prompt response.

I tried “https://yourvcloud.server.url/api/versions” but landed up in error
as follows :

java.lang.IllegalArgumentException: Error parsing media type
’text/html,application/xhtml+xml,image/webp,application/xml; q=0.9,/;
q=0.8’

knife vc login - gives me

ERROR: RestClient::ResourceNotFound: 404 Resource Not Found

I also tried configuring URL in the VCloud director as mentioned in the
following document but still get the same error.

http://pubs.vmware.com/vcd-51/index.jsp#com.vmware.vcloud.api.doc_51/GUID-F4BF9D5D-EF66-4D36-A6EB-2086703F6E37.html

Thanks.

On Sat, Jun 7, 2014 at 1:20 AM, Marco Betti m.betti@gmail.com wrote:

The url you have configured in your example could be too deep.
Usually you only have to specify vcloud director fqdn listening on https
port, without any web-context.
In order to verify the correct url, you should try to list supported api
versions from your vcloud director installation (you should receive an xml
answer):
https://yourvcloud.server.url/api/versions

For previous example what has to be configured for knife-vcloud is just:
yourvcloud.server.url

You can try the configuration with:
knife vc login

If previous command gives a positive answer please read carefully
knife-vcloud Readme for what concerns vcloud login configuration, IDs and
names and verify what kind of account you are using:

  • when a vcloud OU administrator, you have to specify --org-login parameter
  • when a vcloud system administrator, you have to specify --org parameter
    (see “Browse multiple organizations”)

Hope this helps.
Greetings,
Marco
I downloaded vcloud plugin from the URL
https://github.com/astratto/knife-vcloud and i setup the configuration
using

knife vc configure command

and entered the details below:

URL - 'https://1.1.1.1/abc/cloud/org/abc-lab/'
username - 'karthik’
Password - abc

where ‘abc-lab’ is the organization name in the vcloud environment. Once
the
configuration file is created, I gave the following command,

knife vc org list

and it returned 404 resource not found error. Any help appreciated.


#4

Can you see vcloud director web console? Is it working properly?

If yes, which is its address?
Il 07/giu/2014 10:20 “Marco Betti” m.betti@gmail.com ha scritto:

The url you have configured in your example could be too deep.
Usually you only have to specify vcloud director fqdn listening on https
port, without any web-context.
In order to verify the correct url, you should try to list supported api
versions from your vcloud director installation (you should receive an xml
answer):
https://yourvcloud.server.url/api/versions

For previous example what has to be configured for knife-vcloud is just:
yourvcloud.server.url

You can try the configuration with:
knife vc login

If previous command gives a positive answer please read carefully
knife-vcloud Readme for what concerns vcloud login configuration, IDs and
names and verify what kind of account you are using:

  • when a vcloud OU administrator, you have to specify --org-login parameter
  • when a vcloud system administrator, you have to specify --org parameter
    (see “Browse multiple organizations”)

Hope this helps.
Greetings,
Marco
I downloaded vcloud plugin from the URL
https://github.com/astratto/knife-vcloud and i setup the configuration
using

knife vc configure command

and entered the details below:

URL - 'https://1.1.1.1/abc/cloud/org/abc-lab/'
username - 'karthik’
Password - abc

where ‘abc-lab’ is the organization name in the vcloud environment. Once
the
configuration file is created, I gave the following command,

knife vc org list

and it returned 404 resource not found error. Any help appreciated.


#5

I could see vCloud director web console at

https://1.2.3.4/

with the admin username and password, i could login to the vCloud system.

https://1.2.3.4/cloud/org/abc-lab

with the username and password designated for the organization, which logs
me in to the organization directly.

On Mon, Jun 9, 2014 at 11:51 AM, Marco Betti m.betti@gmail.com wrote:

Can you see vcloud director web console? Is it working properly?

If yes, which is its address?
Il 07/giu/2014 10:20 “Marco Betti” m.betti@gmail.com ha scritto:

The url you have configured in your example could be too deep.
Usually you only have to specify vcloud director fqdn listening on https
port, without any web-context.
In order to verify the correct url, you should try to list supported api
versions from your vcloud director installation (you should receive an xml
answer):
https://yourvcloud.server.url/api/versions

For previous example what has to be configured for knife-vcloud is just:
yourvcloud.server.url

You can try the configuration with:
knife vc login

If previous command gives a positive answer please read carefully
knife-vcloud Readme for what concerns vcloud login configuration, IDs and
names and verify what kind of account you are using:

  • when a vcloud OU administrator, you have to specify --org-login
    parameter
  • when a vcloud system administrator, you have to specify --org parameter
    (see “Browse multiple organizations”)

Hope this helps.
Greetings,
Marco
I downloaded vcloud plugin from the URL
https://github.com/astratto/knife-vcloud and i setup the configuration
using

knife vc configure command

and entered the details below:

URL - 'https://1.1.1.1/abc/cloud/org/abc-lab/'
username - 'karthik’
Password - abc

where ‘abc-lab’ is the organization name in the vcloud environment. Once
the
configuration file is created, I gave the following command,

knife vc org list

and it returned 404 resource not found error. Any help appreciated.


#6

if https://1.2.3.4/api/versions

is not displaying info regarding apis there is probably something to check
on vcloud director installation/configuration.

I cannot check with vcloud sysadmins before next week when I’ll be back to
work.

Cheers,
Marco
Il 09/giu/2014 21:02 “Karthik Jayaraman” aswin88us@gmail.com ha scritto:

I could see vCloud director web console at

https://1.2.3.4/

with the admin username and password, i could login to the vCloud system.

https://1.2.3.4/cloud/org/abc-lab

with the username and password designated for the organization, which logs
me in to the organization directly.

On Mon, Jun 9, 2014 at 11:51 AM, Marco Betti m.betti@gmail.com wrote:

Can you see vcloud director web console? Is it working properly?

If yes, which is its address?
Il 07/giu/2014 10:20 “Marco Betti” m.betti@gmail.com ha scritto:

The url you have configured in your example could be too deep.
Usually you only have to specify vcloud director fqdn listening on https
port, without any web-context.
In order to verify the correct url, you should try to list supported api
versions from your vcloud director installation (you should receive an xml
answer):
https://yourvcloud.server.url/api/versions

For previous example what has to be configured for knife-vcloud is just:
yourvcloud.server.url

You can try the configuration with:
knife vc login

If previous command gives a positive answer please read carefully
knife-vcloud Readme for what concerns vcloud login configuration, IDs and
names and verify what kind of account you are using:

  • when a vcloud OU administrator, you have to specify --org-login
    parameter
  • when a vcloud system administrator, you have to specify --org
    parameter (see “Browse multiple organizations”)

Hope this helps.
Greetings,
Marco
I downloaded vcloud plugin from the URL
https://github.com/astratto/knife-vcloud and i setup the configuration
using

knife vc configure command

and entered the details below:

URL - 'https://1.1.1.1/abc/cloud/org/abc-lab/'
username - 'karthik’
Password - abc

where ‘abc-lab’ is the organization name in the vcloud environment. Once
the
configuration file is created, I gave the following command,

knife vc org list

and it returned 404 resource not found error. Any help appreciated.


#7

I changed my knife[:vcloud_url] to ‘https://1.2.3.4’ (Removed the last /).
Now i get the follow error.

ERROR: VCloudClient::UnauthorizedAccess: Client not authorized. Please
check your credentials.

On Mon, Jun 9, 2014 at 12:11 PM, Marco Betti m.betti@gmail.com wrote:

if https://1.2.3.4/api/versions

is not displaying info regarding apis there is probably something to check
on vcloud director installation/configuration.

I cannot check with vcloud sysadmins before next week when I’ll be back to
work.

Cheers,
Marco
Il 09/giu/2014 21:02 “Karthik Jayaraman” aswin88us@gmail.com ha scritto:

I could see vCloud director web console at

https://1.2.3.4/

with the admin username and password, i could login to the vCloud system.

https://1.2.3.4/cloud/org/abc-lab

with the username and password designated for the organization, which
logs me in to the organization directly.

On Mon, Jun 9, 2014 at 11:51 AM, Marco Betti m.betti@gmail.com wrote:

Can you see vcloud director web console? Is it working properly?

If yes, which is its address?
Il 07/giu/2014 10:20 “Marco Betti” m.betti@gmail.com ha scritto:

The url you have configured in your example could be too deep.
Usually you only have to specify vcloud director fqdn listening on
https port, without any web-context.
In order to verify the correct url, you should try to list supported
api versions from your vcloud director installation (you should receive an
xml answer):
https://yourvcloud.server.url/api/versions

For previous example what has to be configured for knife-vcloud is just:
yourvcloud.server.url

You can try the configuration with:
knife vc login

If previous command gives a positive answer please read carefully
knife-vcloud Readme for what concerns vcloud login configuration, IDs and
names and verify what kind of account you are using:

  • when a vcloud OU administrator, you have to specify --org-login
    parameter
  • when a vcloud system administrator, you have to specify --org
    parameter (see “Browse multiple organizations”)

Hope this helps.
Greetings,
Marco
I downloaded vcloud plugin from the URL
https://github.com/astratto/knife-vcloud and i setup the configuration
using

knife vc configure command

and entered the details below:

URL - 'https://1.1.1.1/abc/cloud/org/abc-lab/'
username - 'karthik’
Password - abc

where ‘abc-lab’ is the organization name in the vcloud environment.
Once the
configuration file is created, I gave the following command,

knife vc org list

and it returned 404 resource not found error. Any help appreciated.


#8

After configuring knife.rb with:
knife vc configure
Please try with:
knife vc login --org-login abc-lab
otherwise you can set:
knife[:vcloud_org_login] = 'abc-lab’
inside knife.rb also

Is https://1.2.3.4/api/versions correctly answering?
Il 09/giu/2014 21:29 “Karthik Jayaraman” aswin88us@gmail.com ha scritto:

I changed my knife[:vcloud_url] to ‘https://1.2.3.4’ (Removed the last
/). Now i get the follow error.

ERROR: VCloudClient::UnauthorizedAccess: Client not authorized. Please
check your credentials.

On Mon, Jun 9, 2014 at 12:11 PM, Marco Betti m.betti@gmail.com wrote:

if https://1.2.3.4/api/versions

is not displaying info regarding apis there is probably something to
check on vcloud director installation/configuration.

I cannot check with vcloud sysadmins before next week when I’ll be back
to work.

Cheers,
Marco
Il 09/giu/2014 21:02 “Karthik Jayaraman” aswin88us@gmail.com ha
scritto:

I could see vCloud director web console at

https://1.2.3.4/

with the admin username and password, i could login to the vCloud system.

https://1.2.3.4/cloud/org/abc-lab

with the username and password designated for the organization, which
logs me in to the organization directly.

On Mon, Jun 9, 2014 at 11:51 AM, Marco Betti m.betti@gmail.com wrote:

Can you see vcloud director web console? Is it working properly?

If yes, which is its address?
Il 07/giu/2014 10:20 “Marco Betti” m.betti@gmail.com ha scritto:

The url you have configured in your example could be too deep.
Usually you only have to specify vcloud director fqdn listening on
https port, without any web-context.
In order to verify the correct url, you should try to list supported
api versions from your vcloud director installation (you should receive an
xml answer):
https://yourvcloud.server.url/api/versions

For previous example what has to be configured for knife-vcloud is
just:
yourvcloud.server.url

You can try the configuration with:
knife vc login

If previous command gives a positive answer please read carefully
knife-vcloud Readme for what concerns vcloud login configuration, IDs and
names and verify what kind of account you are using:

  • when a vcloud OU administrator, you have to specify --org-login
    parameter
  • when a vcloud system administrator, you have to specify --org
    parameter (see “Browse multiple organizations”)

Hope this helps.
Greetings,
Marco
I downloaded vcloud plugin from the URL
https://github.com/astratto/knife-vcloud and i setup the
configuration using

knife vc configure command

and entered the details below:

URL - 'https://1.1.1.1/abc/cloud/org/abc-lab/'
username - 'karthik’
Password - abc

where ‘abc-lab’ is the organization name in the vcloud environment.
Once the
configuration file is created, I gave the following command,

knife vc org list

and it returned 404 resource not found error. Any help appreciated.


#9

Thanks for your response.

Tried that one too. no luck.Still getting the following error:

ERROR: VCloudClient::UnauthorizedAccess: Client not authorized. Please
check your credentials.

On Mon, Jun 9, 2014 at 1:29 PM, Marco Betti m.betti@gmail.com wrote:

After configuring knife.rb with:
knife vc configure
Please try with:
knife vc login --org-login abc-lab
otherwise you can set:
knife[:vcloud_org_login] = 'abc-lab’
inside knife.rb also

Is https://1.2.3.4/api/versions correctly answering?
Il 09/giu/2014 21:29 “Karthik Jayaraman” aswin88us@gmail.com ha scritto:

I changed my knife[:vcloud_url] to ‘https://1.2.3.4’ (Removed the last
/). Now i get the follow error.

ERROR: VCloudClient::UnauthorizedAccess: Client not authorized. Please
check your credentials.

On Mon, Jun 9, 2014 at 12:11 PM, Marco Betti m.betti@gmail.com wrote:

if https://1.2.3.4/api/versions

is not displaying info regarding apis there is probably something to
check on vcloud director installation/configuration.

I cannot check with vcloud sysadmins before next week when I’ll be back
to work.

Cheers,
Marco
Il 09/giu/2014 21:02 “Karthik Jayaraman” aswin88us@gmail.com ha
scritto:

I could see vCloud director web console at

https://1.2.3.4/

with the admin username and password, i could login to the vCloud
system.

https://1.2.3.4/cloud/org/abc-lab

with the username and password designated for the organization, which
logs me in to the organization directly.

On Mon, Jun 9, 2014 at 11:51 AM, Marco Betti m.betti@gmail.com wrote:

Can you see vcloud director web console? Is it working properly?

If yes, which is its address?
Il 07/giu/2014 10:20 “Marco Betti” m.betti@gmail.com ha scritto:

The url you have configured in your example could be too deep.
Usually you only have to specify vcloud director fqdn listening on
https port, without any web-context.
In order to verify the correct url, you should try to list supported
api versions from your vcloud director installation (you should receive an
xml answer):
https://yourvcloud.server.url/api/versions

For previous example what has to be configured for knife-vcloud is
just:
yourvcloud.server.url

You can try the configuration with:
knife vc login

If previous command gives a positive answer please read carefully
knife-vcloud Readme for what concerns vcloud login configuration, IDs and
names and verify what kind of account you are using:

  • when a vcloud OU administrator, you have to specify --org-login
    parameter
  • when a vcloud system administrator, you have to specify --org
    parameter (see “Browse multiple organizations”)

Hope this helps.
Greetings,
Marco
I downloaded vcloud plugin from the URL
https://github.com/astratto/knife-vcloud and i setup the
configuration using

knife vc configure command

and entered the details below:

URL - 'https://1.1.1.1/abc/cloud/org/abc-lab/'
username - 'karthik’
Password - abc

where ‘abc-lab’ is the organization name in the vcloud environment.
Once the
configuration file is created, I gave the following command,

knife vc org list

and it returned 404 resource not found error. Any help appreciated.


#10

I simulated REST request via cURL software and dispatched a request to
vCloud as follows :

curl -i -k -H “Accept:application/*+xml;version=1.5” -u
’admin@abc-lab:password’
-X POST https://1.2.3.4

As mentioned in

But i got the following response:

HTTP/1.1 302 Found
Date: Mon, 09 Jun 2014 21:32:01 GMT
Location: https://1.2.3.4
Content-Length: 0

But i should have got HTTP 200 as response. Anything wrong with my vCloud
configuration ?

Thanks,
Karthik

On Mon, Jun 9, 2014 at 2:09 PM, Karthik Jayaraman aswin88us@gmail.com
wrote:

Thanks for your response.

Tried that one too. no luck.Still getting the following error:

ERROR: VCloudClient::UnauthorizedAccess: Client not authorized. Please
check your credentials.

On Mon, Jun 9, 2014 at 1:29 PM, Marco Betti m.betti@gmail.com wrote:

After configuring knife.rb with:
knife vc configure
Please try with:
knife vc login --org-login abc-lab
otherwise you can set:
knife[:vcloud_org_login] = 'abc-lab’
inside knife.rb also

Is https://1.2.3.4/api/versions correctly answering?
Il 09/giu/2014 21:29 “Karthik Jayaraman” aswin88us@gmail.com ha
scritto:

I changed my knife[:vcloud_url] to ‘https://1.2.3.4’ (Removed the last
/). Now i get the follow error.

ERROR: VCloudClient::UnauthorizedAccess: Client not authorized. Please
check your credentials.

On Mon, Jun 9, 2014 at 12:11 PM, Marco Betti m.betti@gmail.com wrote:

if https://1.2.3.4/api/versions

is not displaying info regarding apis there is probably something to
check on vcloud director installation/configuration.

I cannot check with vcloud sysadmins before next week when I’ll be back
to work.

Cheers,
Marco
Il 09/giu/2014 21:02 “Karthik Jayaraman” aswin88us@gmail.com ha
scritto:

I could see vCloud director web console at

https://1.2.3.4/

with the admin username and password, i could login to the vCloud
system.

https://1.2.3.4/cloud/org/abc-lab

with the username and password designated for the organization, which
logs me in to the organization directly.

On Mon, Jun 9, 2014 at 11:51 AM, Marco Betti m.betti@gmail.com
wrote:

Can you see vcloud director web console? Is it working properly?

If yes, which is its address?
Il 07/giu/2014 10:20 “Marco Betti” m.betti@gmail.com ha scritto:

The url you have configured in your example could be too deep.
Usually you only have to specify vcloud director fqdn listening on
https port, without any web-context.
In order to verify the correct url, you should try to list supported
api versions from your vcloud director installation (you should receive an
xml answer):
https://yourvcloud.server.url/api/versions

For previous example what has to be configured for knife-vcloud is
just:
yourvcloud.server.url

You can try the configuration with:
knife vc login

If previous command gives a positive answer please read carefully
knife-vcloud Readme for what concerns vcloud login configuration, IDs and
names and verify what kind of account you are using:

  • when a vcloud OU administrator, you have to specify --org-login
    parameter
  • when a vcloud system administrator, you have to specify --org
    parameter (see “Browse multiple organizations”)

Hope this helps.
Greetings,
Marco
I downloaded vcloud plugin from the URL
https://github.com/astratto/knife-vcloud and i setup the
configuration using

knife vc configure command

and entered the details below:

URL - 'https://1.1.1.1/abc/cloud/org/abc-lab/'
username - 'karthik’
Password - abc

where ‘abc-lab’ is the organization name in the vcloud environment.
Once the
configuration file is created, I gave the following command,

knife vc org list

and it returned 404 resource not found error. Any help appreciated.