Error while Bootstrap


#1

Hi,

I’m facing an issue while bootstrap.
I’m using Jenkins on windows 2008 server to bootstrap newly created VM via
jenkins job. unfortunately it breaks after rendering, here is the bootstrap
command

c:\opscode\chefdk\bin\knife.bat bootstrap windows winrm 10.166.144.44 -x
administrator -P password -N TestVm1 --bootstrap-version 11

Waiting for remote response before bootstrap.10.166.144.44 .
10.166.144.44 Response received.
Remote node responded after 0.03 minutes.
Bootstrapping Chef on 10.166.144.44
10.166.144.44 "Rendering “C:\Users\ADMINI~1\AppData\Local\Temp\bootstrap-1224-1
418386804.bat” chunk 1"
10.166.144.44 "Rendering “C:\Users\ADMINI~1\AppData\Local\Temp\bootstrap-1224-1
418386804.bat” chunk 2"
10.166.144.44 "Rendering “C:\Users\ADMINI~1\AppData\Local\Temp\bootstrap-1224-1
418386804.bat” chunk 3"
10.166.144.44 "Rendering “C:\Users\ADMINI~1\AppData\Local\Temp\bootstrap-1224-1
418386804.bat” chunk 4"
10.166.144.44 "Rendering “C:\Users\ADMINI~1\AppData\Local\Temp\bootstrap-1224-1
418386804.bat” chunk 5"
ERROR: ThreadError: can’t create Thread (22)
+ CategoryInfo : NotSpecified: (ERROR: ThreadEr…ate Thread (22)
:String) [], RemoteException
+ FullyQualifiedErrorId : NativeCommandError

ERROR: The object you are looking for could not be found
Response: node ‘TestVM1’ not found
ERROR: The object you are looking for could not be found
Response: node ‘TestVM1’ not found

Same commands works fine if i run it on powershell command line.
Am i doing something wrong? Please advice.

Thanks,
Ketan