# Fatal error by chef-compliance-ctl reconfigure

**URL:** https://discourse.chef.io/t/fatal-error-by-chef-compliance-ctl-reconfigure/8335
**Category:** Chef Infra (archive)
**Created:** [April 26, 2016, 8:02pm UTC](https://discourse.chef.io/t/fatal-error-by-chef-compliance-ctl-reconfigure/8335 "2016-04-26T20:02:29Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Michael1](https://avatars.discourse-cdn.com/v4/letter/m/eada6e/32.png) [@Michael1](https://discourse.chef.io/u/Michael1)
#### Post date: [April 26, 2016, 8:02pm UTC](https://discourse.chef.io/t/fatal-error-by-chef-compliance-ctl-reconfigure/8335/1 "2016-04-26T20:02:29Z")

</div>

Hi

I’m getting a fatal error by configuring chef-compliance

[2016-04-26T21:54:02+02:00] ERROR: Running exception handlers  
Running handlers complete  
[2016-04-26T21:54:02+02:00] ERROR: Exception handlers complete  
Chef Client failed. 9 resources updated in 01 minutes 19 seconds  
[2016-04-26T21:54:02+02:00] FATAL: Stacktrace dumped to /opt/chef-compliance/embedded/cookbooks/cache/chef-stacktrace.out  
[2016-04-26T21:54:02+02:00] FATAL: Please provide the contents of the stacktrace.out file if you file a bug report  
[2016-04-26T21:54:02+02:00] FATAL: Mixlib::ShellOut::ShellCommandFailed: enterprise\_pg\_database[chef\_compliance] (chef-compliance::\_postgresql-enable line 47) had an error: Mixlib::ShellOut::ShellCommandFailed: execute[create\_database\_chef\_compliance] (/opt/chef-compliance/embedded/cookbooks/cache/cookbooks/enterprise/providers/pg\_database.rb line 19) had an error: Mixlib::ShellOut::ShellCommandFailed: Expected process to exit with [0], but received ‘1’  
---- Begin output of createdb --template template0 --encoding UTF-8 chef\_compliance ----  
STDOUT:  
STDERR: createdb: could not connect to database template1: FATAL: no pg\_hba.conf entry for host “[local]”, user “chef-pgsql”, database “template1”, SSL off  
---- End output of createdb --template template0 --encoding UTF-8 chef\_compliance ----  
Ran createdb --template template0 --encoding UTF-8 chef\_compliance returned 1

It seems that the user does not exist in the pg\_hba.conf file.  
cat /var/opt/opscode/postgresql/9.2/data/pg\_hba.conf  
local all opscode-pgsql peer

host all opscode-pgsql samehost md5

host all all 127.0.0.1/32 md5  
host all all ::1/128 md5

How to change this user?

---

<div class="post-metadata">

### Author: ![iterra](https://sea2.discourse-cdn.com/flex016/user_avatar/discourse.chef.io/iterra/32/1743_2.png) [@iterra](https://discourse.chef.io/u/iterra)
#### Post date: [February 15, 2017, 9:57am UTC](https://discourse.chef.io/t/fatal-error-by-chef-compliance-ctl-reconfigure/8335/2 "2017-02-15T09:57:00Z")

</div>

Michael,

Did you figure this out ? Seem to be hitting same problem…

P

---

<div class="post-metadata">

### Author: ![Michael1](https://avatars.discourse-cdn.com/v4/letter/m/eada6e/32.png) [@Michael1](https://discourse.chef.io/u/Michael1)
#### Post date: [February 15, 2017, 2:29pm UTC](https://discourse.chef.io/t/fatal-error-by-chef-compliance-ctl-reconfigure/8335/3 "2017-02-15T14:29:21Z")

</div>

No, We did use a separate server for Chef Compliance now and not on the same server as Chef Server
