Gem releases supporting WinRM v2

#1

Two weeks ago a new set of winrm gems was released (winrm, winrm-fs and winrm-elevated) which included:

  • Compatibility with Windows Nano server
  • Much improved file copy performance
  • A ruby implementation of powershel remoting
  • Cleaned up API and many bug fixes

Over the last week we have released updates to several products and gems that adopt these winrm v2 enhancements:

One thing I want to point pout to chef-dk users is that updating to any of the above gems may cause gem conflicts in your current chef-dk environment especially if you use the appbundle-updater to update your dk. The next chef-dk releasing later this month will fix this and ensure that all packaged gems are winrm v2 compliant. If you would like to test a new version of the chef-dk that has all of these gems included, you can install from the current channel. Last night’s version 0.18.13 is the first release that has all of these gems included.

To install from current you can run:

curl https://omnitruck.chef.io/install.sh | sudo bash -s -- -c current -P chefdk -v 0.18.13

or

. { iwr -useb https://omnitruck.chef.io/install.ps1 } | iex; install -channel current -project chefdk -version 0.18.13

Please let us know if you encounter any issues with these gems and tools in these current versions of chef-dk so that we can address the issues before release.

Thanks,
Matt

0 Likes