Issue with omni-server defaulting to 443/80


#1

Im trying to stand up omni server within vagrant, but I want to forward
high ports from my host to the omni ui. When I do this the omni server is
redirecting my requests to port 8443 and squashing the request (actually i
think the login page generates a non relative login button). Anyhow The
short/quick fix is to configure omni chef to use some high port for the
api/webui stuff. I looked around, and cant find where to set the desired
port in omni chef-server. Maybe someone can enlighten me?

I just “fixed” it with an ipfw rule for now, but that i consider to be a
bigger hack :slight_smile:

Thanks,
Jesse


#2

On Wednesday, February 6, 2013 at 7:15 AM, Jesse Nelson wrote:

Im trying to stand up omni server within vagrant, but I want to forward high ports from my host to the omni ui. When I do this the omni server is redirecting my requests to port 8443 and squashing the request (actually i think the login page generates a non relative login button). Anyhow The short/quick fix is to configure omni chef to use some high port for the api/webui stuff. I looked around, and cant find where to set the desired port in omni chef-server. Maybe someone can enlighten me?

I just “fixed” it with an ipfw rule for now, but that i consider to be a bigger hack :slight_smile:

Thanks,
Jesse

After installing the package, but before running chef-server-ctl reconfigure, you can tweak chef-server settings in /etc/chef-server/chef-server.rb – these become attributes in the chef-solo run that configures the installation.

In your case, these are the relevant settings:

nginx[‘ssl_port’] = 443
nginx[‘non_ssl_port’] = 80

The cookbooks are here: https://github.com/opscode/omnibus-chef/tree/master/files/chef-server-cookbooks if you want to look further.


Daniel DeLeo


#3

Thanks exactly what I was looking for.

On Wed, Feb 6, 2013 at 9:14 AM, Daniel DeLeo dan@kallistec.com wrote:

On Wednesday, February 6, 2013 at 7:15 AM, Jesse Nelson wrote:

Im trying to stand up omni server within vagrant, but I want to forward
high ports from my host to the omni ui. When I do this the omni server is
redirecting my requests to port 8443 and squashing the request (actually i
think the login page generates a non relative login button). Anyhow The
short/quick fix is to configure omni chef to use some high port for the
api/webui stuff. I looked around, and cant find where to set the desired
port in omni chef-server. Maybe someone can enlighten me?

I just “fixed” it with an ipfw rule for now, but that i consider to be a
bigger hack :slight_smile:

Thanks,
Jesse

After installing the package, but before running chef-server-ctl reconfigure, you can tweak chef-server settings in
/etc/chef-server/chef-server.rb – these become attributes in the chef-solo
run that configures the installation.

In your case, these are the relevant settings:

nginx[‘ssl_port’] = 443
nginx[‘non_ssl_port’] = 80

The cookbooks are here:
https://github.com/opscode/omnibus-chef/tree/master/files/chef-server-cookbooksif you want to look further.


Daniel DeLeo