Issue with test-kitchen - failed to create vra VM

Am trying to create a test-kitchen vm using a vRA blueprint. Running into an error “[Custom property ‘__Notes’ cannot be from predefined custom properties].” I am using the kitchen-vra v1.3.0 gem and have the 0.16.28 ChefDK installed. I am aboe to create the vm from the vRA portal, but am unable to get a VM created with test-kitchen. I have tried several differnet blueprints, and have tried adding a note and not adding a note, and get the same error in each case. The request is getting far enough to generate the catalog request in vRA, but is then failing when trying to apply that request.

Not sure if this makes any difference, but this is an internal testing vRA instance, using self-signed certs, and therefore I am using the verify_ssl: false flag.

I can post the kitchen.yml and kitchen log output if anyone is interested.

Thanks in advance for any help.

The issue here was with a change in vRA 7.0.1 where the __notes property is no longer writable. There is an outstanding pull request to resolve the issue. This is an issue on vRA => 7.0.1

Yep, I’m finishing off VMworld, then going to validate the vra-gem PR.