JSON BUG: to_json stack level too deep


#1

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hello!

The json rubygem released the other day, v1.4.3, introduced an issue
with ohai and chef-clients being saved on the Chef Server. This
affects RubyGems installations of Chef in the last couple days for
users of Chef with solo or client/server, including Platform
customers. The fix for now:

sudo gem uninstall -aIx json
sudo gem install -v 1.4.2 json

We will be releasing ohai and chef with a version dependency < 1.4.3
soon.

This doesn’t affect users that installed via .deb/.rpm packages as the
version of JSON available is older.


Opscode, Inc
Joshua Timberman, Senior Solutions Engineer
C: 720.334.RUBY E: joshua@opscode.com

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (Darwin)

iEYEARECAAYFAkvjbWgACgkQO97WSdVpzT25bgCeJ2al4IffT/ZYPrMKrr9aILfo
CrYAn0RL/mshvSeJXJ3y+GbyV4emLqpG
=zIud
-----END PGP SIGNATURE-----