Knife ec2 create is not working


#1

After updating chef gems in my chef server, when i ran knife ec2 instance.

at some point , it was not able to install ruby gem in my node machine.

./lib/rubygems/custom_require.rb:54: warning: parenthesize argument(s) for
future version
./lib/rubygems/custom_require.rb:57:in require': undefined methodend_with?'
for “no such file to load – Win32API”:String (NoMethodError)
from ./lib/rubygems/config_file.rb:55
from ./lib/rubygems/custom_require.rb:36:in gem_original_require' from ./lib/rubygems/custom_require.rb:36:inrequire’
from ./lib/rubygems/gem_runner.rb:8
from ./lib/rubygems/custom_require.rb:36:in gem_original_require' from ./lib/rubygems/custom_require.rb:36:inrequire’
from setup.rb:25

What would be the problem.

why knife boostrapping s not working in node and install correct version of
ruby / gems

Any thing i need to do my end.

I am using 64 bit ec2 centos node and chef-server s in 32-bit ec2 centos
machine

Please help me to resolve it