Machine resource ssh user


#1

How would one go about setting the ssh user to use in the machine resource?

I keep getting this:

INFO: Executing sudo pwd on ubuntu@10.0.1.92
[2014-12-22T20:31:55-05:00] INFO: Executing sudo pwd on ubuntu@10.0.1.92

I need to set “ubuntu” here to something else.


Thanks,

Mark


#2

This has been resolved on IRC. Have to set machine_spec.location[‘ssh_username’] if using the Fog driver.

–Noah

On Dec 22, 2014, at 5:36 PM, Mark Pimentel markpimentel22@gmail.com wrote:

How would one go about setting the ssh user to use in the machine resource?

I keep getting this:

INFO: Executing sudo pwd on ubuntu@10.0.1.92
[2014-12-22T20:31:55-05:00] INFO: Executing sudo pwd on ubuntu@10.0.1.92

I need to set “ubuntu” here to something else.


Thanks,

Mark