Net-ssh dependency issue with older version of Chef 10.14.4


#1

I need to install Chef on a new persons laptop. We are still on Chef
10.14.4. When we attempt to run the command:

gem install chef -v 10.14.4 --no-ri --no-rdoc

We get the following error:

Unable to resolve dependencies: chef requires net-ssh (~> 2.2.2);
net-ssh-multi requires net-ssh (>= 2.1.4); net-ssh-gateway requires net-ssh
(>= 2.6.5)

What can I do to get around this issue or even resolve it?

Thanks,


Jay Flowers

http://jayflowers.com


#2

On Friday, February 15, 2013 at 5:32 AM, Jay Flowers wrote:

I need to install Chef on a new persons laptop. We are still on Chef 10.14.4. When we attempt to run the command:

gem install chef -v 10.14.4 --no-ri --no-rdoc

We get the following error:

Unable to resolve dependencies: chef requires net-ssh (~> 2.2.2); net-ssh-multi requires net-ssh (>= 2.1.4); net-ssh-gateway requires net-ssh (>= 2.6.5)

What can I do to get around this issue or even resolve it?

Thanks,


Jay Flowers

http://jayflowers.com

Is there a particular change keeping you on that version? This stuff is solved in the latest 10.x release.

Anyway, someone blogged about this recently:

http://blog.karekinian.com/2013/02/14/how-to-install-chef-0.10.4/


Daniel DeLeo