Semantics proposal on Resource 'attributes'


#1

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I propose we stop referring to the parameters passed to resources as
attributes, and call them parameters unilaterally. For example, a
file’s owner, or package’s version. I have two main reasons for this.

  1. Semantic cohesion with the ‘params’ hash in definitions.
  2. Potential confusion with node, role or cookbook attributes.
  3. (Bonus!) Folks in #chef-hacking are supportive of this.

This is definitely a semantics topic, but an important one.
Documentation updates to the wiki will be required, and potentially
other pages. This also may require a mental shift, depending on how we
talk about this aspect of Chef.


Opscode, Inc
Joshua Timberman, Senior Solutions Engineer
C: 720.334.RUBY E: joshua@opscode.com

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (Darwin)

iEYEARECAAYFAkuqhwgACgkQO97WSdVpzT2+5gCeLxaHfVULeAIA/yZTUnHWc33s
Aq8AniPQ1FmK0xw0o/K1OXHFhZ0rWZmA
=JQcm
-----END PGP SIGNATURE-----