Solr maxFieldLength setting


#1

Hi Chefs…

I noticed tonight I was losing nodes in the solr index and after reading
http://tickets.opscode.com/browse/CHEF-2346, i bumped up the maxFieldLength
setting.
After restarting/reindexing all my nodes started showing up again, but
after a while the API server crashed with this:
http://pastie.org/3625369

I only raised the limit to 60k, but that seems too much. Solr is on a
different node from the API, and the Solr node doesn’t seem to be under any
pressure. Is there a good rule of thumb for setting this field?

Thanks!


Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.


#2

What’s the -Xmx and -Xms for solr? And how much ram do you have? how
many workers for chef?

Adam

On Sun, Mar 18, 2012 at 7:38 PM, Chris grocerylist@gmail.com wrote:

Hi Chefs…

I noticed tonight I was losing nodes in the solr index and after
reading http://tickets.opscode.com/browse/CHEF-2346, i bumped up the
maxFieldLength setting.
After restarting/reindexing all my nodes started showing up again, but after
a while the API server crashed with this:
http://pastie.org/3625369

I only raised the limit to 60k, but that seems too much. Solr is on a
different node from the API, and the Solr node doesn’t seem to be under any
pressure. Is there a good rule of thumb for setting this field?

Thanks!


Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.


Opscode, Inc.
Adam Jacob, Chief Customer Officer
T: (206) 619-7151 E: adam@opscode.com


#3

1gb for solr, and 2 workers and 4gb for the API. The workers would consume all the ram and the OS would start swapping and crash shortly after that

Sent from a phone

On Mar 19, 2012, at 7:48 PM, Adam Jacob adam@opscode.com wrote:

What’s the -Xmx and -Xms for solr? And how much ram do you have? how
many workers for chef?

Adam

On Sun, Mar 18, 2012 at 7:38 PM, Chris grocerylist@gmail.com wrote:

Hi Chefs…

I noticed tonight I was losing nodes in the solr index and after
reading http://tickets.opscode.com/browse/CHEF-2346, i bumped up the
maxFieldLength setting.
After restarting/reindexing all my nodes started showing up again, but after
a while the API server crashed with this:
http://pastie.org/3625369

I only raised the limit to 60k, but that seems too much. Solr is on a
different node from the API, and the Solr node doesn’t seem to be under any
pressure. Is there a good rule of thumb for setting this field?

Thanks!


Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.


Opscode, Inc.
Adam Jacob, Chief Customer Officer
T: (206) 619-7151 E: adam@opscode.com