TESTING: Chef 0.8.x Ubuntu PPA


#1

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Ohai!

We’re very close to Chef 0.8.6 package release for Debian and Ubuntu.
To keep them separate from the repository Opscode hosts
(apt.opscode.com) for testing purposes, I created a PPA on Launchpad
for the in-development “prerelease” packages of Chef 0.8.6. If you
have a system available for testing, please give them a shot.

The PPA itself is enabled for Karmic and Lucid only, and can be found
here:

https://launchpad.net/~jtimberman/+archive/opschef/+packages

Clients:

 sudo apt-get install chef

Server:

 sudo apt-get install chef-server

(chef-server-webui provides the WebUI, and is optional)

If you have 0.7.x server that was installed from Debian packages,
upgrading might not work cleanly, if at all. This needs testing.

Thank you!


Opscode, Inc
Joshua Timberman, Senior Solutions Engineer
C: 720.334.RUBY E: joshua@opscode.com

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (Darwin)

iEYEARECAAYFAkuYp7kACgkQO97WSdVpzT2AyACcCcKhlaAYD3EgXHuDzhnDFDqk
Q84Ani687YYnoEjJBYdg5eCHgWHbGdjR
=MLTs
-----END PGP SIGNATURE-----


#2

On Thu, Mar 11, 2010 at 3:20 AM, Joshua Timberman joshua@opscode.com wrote:

testing purposes, I created a PPA on Launchpad for the in-development
"prerelease" packages of Chef 0.8.6. If you have a system available for
testing, please give them a shot.

This installed correctly however I cannot log into the webui using
admin and my password. I was prompted for webui admin password and
the password was updated in /etc/chef/webui.rb correctly, but when i
try to log into web ui, all i see is
"Could not complete logging in."

my password is alphanumeric, so no wacky characters

The /var/log/chef/server-webui.log doesn’t report any errors

I did get one error during install to the console

Setting up chef-server-webui (0.8.6-8) …

  • Starting chef-server-webui
    ~ In 5352

                         [fail]
    

~ Failed loading ChefServerWebui (404 “Object Not Found”)

but the webui came up fine. I’ve restarted the webui server, no error
but still no luck logging in.

I’m installing on a fresh ec2 instance ami-1515f67c, which is the
official karmic ami AFAIK

P.S. I also p@ssw0rd1 but still no luck.

Feedback on installer: When entering new passwords during installer
that are shadowed to the screen, i suppose it’s standard practice to
have confirmation input to ensure password wasn’t fat fingered, as
annoying as it is to enter passwords twice.


#3

On Fri, Mar 12, 2010 at 9:33 AM, Douglas Hubler douglas@hubler.us wrote:

On Thu, Mar 11, 2010 at 3:20 AM, Joshua Timberman joshua@opscode.com wrote:

testing purposes, I created a PPA on Launchpad for the in-development
"prerelease" packages of Chef 0.8.6. If you have a system available for
testing, please give them a shot.

This installed correctly however I cannot log into the webui using

This may not make sense, but…

I was verifying i use knife commands like listing nodes and that
worked fine. Then for ha-ha’s i tried the webui login again and now
it worked!

Next time i start a new instance, I’ll try to duplicate this and send
more details. For now, I’m off and running, thanks, this package was
great timing.