Trying to delete an enterprise with a space in the name


#1

When setting automate up for the first time I accidentally placed a space in the enterprise name. When I run delivery-ctl delete-enterprise “dev instance” I get the following error.

Failed to run command: delete enterprise "Dev Instance"
Error: This command was not used with the correct arguments.
Usage: delivery-ctl delete-enterprise ENTERPRISE-NAME

I have also tried escaping the space with a \ and that doesn’t work either.

Thanks!


#2

Hi there, thanks for the note. I think you may have encountered a bug here – I’ve referred to our engineering team to review. Sorry for the trouble!

Cheers,
Megan


#3

We will fix the delivery-ctl setup prompts to prevent users from creating enterprises with spaces.

To delete the one you created, try this:
delivery-ctl delete-enterprise My%20Enterprise

Hope that helps!
Megan


#4

I have a similar issue with delete project…I tried the %20 approach and it doesn’t work:

[root@chef-automate-1 ec2-user]# /opt/delivery/bin/delivery-ctl delete-project FirstFuelEnterprise FirstFuel Chef%20Bootstrap
Project not found: ‘FirstFuelEnterprise/FirstFuel/Chef%20Bootstrap’