apache2 cookbook , cannot seem to disable the default site


#1

hi folks i am using the latest apache2 cookbook from opscode to
configure my apache server I have already added my own virtual hosts
recipes, for some reason I cannot seem to be able to disable the default
and default-ssl sites , I red the README and tried apache_site “default”
“disable” , apache_site “default” “false” but nothing seems to trigger
the a2dissite code.

Any Ideas?

Thanks,
Kobi


#2

Hey Kobi,

I ran into that problem, and fixed it here:
http://tickets.opscode.com/browse/COOK-1315

Basically, it’s now an attribute, named default_site_enabled with a
value of true/false.

It has not been released into the cookbook versions yet, should make
it into 1.1.10.

-M

On Sun, Jun 24, 2012 at 5:14 AM, Kobi Biton kobi.biton@gmail.com wrote:

hi folks i am using the latest apache2 cookbook from opscode to configure my
apache server I have already added my own virtual hosts recipes, for some
reason I cannot seem to be able to disable the default and default-ssl sites
, I red the README and tried apache_site “default” “disable” , apache_site
"default" “false” but nothing seems to trigger the a2dissite code.

Any Ideas?

Thanks,
Kobi


#3

great, thanks a lot for the ref.

eventually I was able to disable the default site by adding the below
code to my custom virtual host recipe:

apache_site “default” do
enable false
end

I figured it out from the module disable example on the readme maybe one
should consider an example snippet on README.rb file?

anyways I am all good now , thanks!

Kobi.

On 06/24/2012 03:13 PM, Mike wrote:

Hey Kobi,

I ran into that problem, and fixed it here:
http://tickets.opscode.com/browse/COOK-1315

Basically, it’s now an attribute, named default_site_enabled with a
value of true/false.

It has not been released into the cookbook versions yet, should make
it into 1.1.10.

-M

On Sun, Jun 24, 2012 at 5:14 AM, Kobi Biton kobi.biton@gmail.com wrote:

hi folks i am using the latest apache2 cookbook from opscode to configure my
apache server I have already added my own virtual hosts recipes, for some
reason I cannot seem to be able to disable the default and default-ssl sites
, I red the README and tried apache_site “default” “disable” , apache_site
"default" “false” but nothing seems to trigger the a2dissite code.

Any Ideas?

Thanks,
Kobi


#4

Glad to hear you got it.

I wanted to minimize the amount of apache reconfiguration done on each
chef run, and since a reconfig triggers an apache reload, I wanted to
prevent that as much as possible as well.
As well as make it configurable outside the cookbook itself, to
maintain a “pristine” installed cookbook.

Curious - does this mean that on a chef run, you’re enabling the
default in apache2::default and the disabling in your custom recipe?

-M

On Sun, Jun 24, 2012 at 8:20 AM, Kobi Biton kobi.biton@gmail.com wrote:

great, thanks a lot for the ref.

eventually I was able to disable the default site by adding the below code
to my custom virtual host recipe:

apache_site “default” do
enable false
end

I figured it out from the module disable example on the readme maybe one
should consider an example snippet on README.rb file?

anyways I am all good now , thanks!

Kobi.

On 06/24/2012 03:13 PM, Mike wrote:

Hey Kobi,

I ran into that problem, and fixed it here:
http://tickets.opscode.com/browse/COOK-1315

Basically, it’s now an attribute, named default_site_enabled with a
value of true/false.

It has not been released into the cookbook versions yet, should make
it into 1.1.10.

-M

On Sun, Jun 24, 2012 at 5:14 AM, Kobi Biton kobi.biton@gmail.com wrote:

hi folks i am using the latest apache2 cookbook from opscode to configure
my
apache server I have already added my own virtual hosts recipes, for some
reason I cannot seem to be able to disable the default and default-ssl
sites
, I red the README and tried apache_site “default” “disable” ,
apache_site
"default" “false” but nothing seems to trigger the a2dissite code.

Any Ideas?

Thanks,
Kobi


#5

Yes you are right I am running the chef::default and then my custom
recipe disabling the default site , by all means its not an elegant
workaround but it works :wink: , I will have to wait for the new attribute
on 1.1.10 … :slight_smile: this will enable me to remove my code snippet.

Kobi.

On 06/24/2012 03:25 PM, Mike wrote:

Glad to hear you got it.

I wanted to minimize the amount of apache reconfiguration done on each
chef run, and since a reconfig triggers an apache reload, I wanted to
prevent that as much as possible as well.
As well as make it configurable outside the cookbook itself, to
maintain a “pristine” installed cookbook.

Curious - does this mean that on a chef run, you’re enabling the
default in apache2::default and the disabling in your custom recipe?

-M

On Sun, Jun 24, 2012 at 8:20 AM, Kobi Biton kobi.biton@gmail.com wrote:

great, thanks a lot for the ref.

eventually I was able to disable the default site by adding the below code
to my custom virtual host recipe:

apache_site “default” do
enable false
end

I figured it out from the module disable example on the readme maybe one
should consider an example snippet on README.rb file?

anyways I am all good now , thanks!

Kobi.

On 06/24/2012 03:13 PM, Mike wrote:

Hey Kobi,

I ran into that problem, and fixed it here:
http://tickets.opscode.com/browse/COOK-1315

Basically, it’s now an attribute, named default_site_enabled with a
value of true/false.

It has not been released into the cookbook versions yet, should make
it into 1.1.10.

-M

On Sun, Jun 24, 2012 at 5:14 AM, Kobi Biton kobi.biton@gmail.com wrote:

hi folks i am using the latest apache2 cookbook from opscode to configure
my
apache server I have already added my own virtual hosts recipes, for some
reason I cannot seem to be able to disable the default and default-ssl
sites
, I red the README and tried apache_site “default” “disable” ,
apache_site
"default" “false” but nothing seems to trigger the a2dissite code.

Any Ideas?

Thanks,
Kobi