AWS - OPSWorks Question


#1

Ohai!

I am not sure if this is the correct place to ask but my googlefu is coming up empty on this one. I am trying to set the environment on my opsworks stack and it’s not working correctly. Here is the json I applied to the stack:

{
“chef_environment”: “production”
}

This is the output of this: Chef::Log.info “Updating environment #{node.chef_environment}”

[2013-08-26T23:09:56+00:00] INFO: Updating environment _default

I am not sure what I am missing. If anyone is familiar with opsworks/chef, any help is appreciated!

Thanks!
Jenn


#2

you need to run chef client with -E production flag, or set the environment
inside client.rb, as environment ‘production’

On Mon, Aug 26, 2013 at 4:26 PM, Jenn Fountain jfountain@meetme.com wrote:

Ohai!

I am not sure if this is the correct place to ask but my googlefu is
coming up empty on this one. I am trying to set the environment on my
opsworks stack and it’s not working correctly. Here is the json I
applied to the stack:

{
“chef_environment”: “production”
}

This is the output of this: Chef::Log.info “Updating environment
#{node.chef_environment}”

[2013-08-26T23:09:56+00:00] INFO: Updating environment _default

I am not sure what I am missing. If anyone is familiar with
opsworks/chef, any help is appreciated!

Thanks!
Jenn