Azure LinuxChefClient hangs on install


#1

We are trying to install the LinuxChefClient for RHEL v7.2 VM and the chef client extension never finishes. We’ve let it run for over a half hour, it just never completes install. We first started with ARM Templates. When that wasn’t working, we switched to trying manually through the Azure Portal using Azure Resource Manager. It too hangs. We’ve also tried Ubuntu and received the same result. However, when we install the Chef Client on a Windows Server 2012 R2 VM, the install completes without error. We’re not seeing any errors or any feedback at all other than the extension remains in the Running Provisioning State. Has anyone come across something similar?


#2

Very strange… its working fine here…
Double check the CHEF extension details on Azure portal, do you have the correct details of your " * Chef Server URL " and check the name of “* Validation Client Name” and upload a WORKING “* Validation Key” and disable the “SSL Verification Mode”

Check from the Linux machine on Azure if you can download the client “wget https://packages.chef.io/files/stable/chefdk/1.4.3/el/7/chefdk-1.4.3-1.el7.x86_64.rpm


#3

We tried and the installations still hang. What’s even more weird is we just tried to install Chef Automate on a VM from the Marketplace and that installation hangs as well.