Bootstrapping first node: Failed to authenticate to the chef server (http 401)

Hi list:
I looked up on this list/Google, but no exact match (while following some ideas that may have helped) found.

If it matters for this case: I don’t have chef-manage installed on the server.

I’m using a workstation-server-node setup.

All three’s firewalls are allowing relevant traffic (80, 443, 22) between them.

Following this guide: chef bootstrap guide
However, getting the error mentioned in OP.

More relevant info: chef_server_url "" validation_client_name "chef-validator" validation_key “/etc/chef/validation.pem”

My knife.rb (on the workstation)

current_dir = File.dirname(FILE)
log_level :info
log_location STDOUT
node_name 'chefnode’
client_key “#{current_dir}/chefadmin.pem"
validation_client_name 'chef-validator’
validation_key “#{current_dir}/(edited)-validator.pem"
chef_server_url ‘https://chef.(edited).com/organizations/(edited)’'
cache_type 'BasicFile’
cache_options( :path => “#{ENV[‘HOME’]}/.chef/checksums” )
cookbook_path [”#{current_dir}/…/cookbooks”]

Your ideas/assistance is most welcome :slight_smile:
If other config files are needed, please ask.
Thank you.

Replying as resolution:

After only 8 hours of messing with this (until I understood that I know everything about the config options, and still it does not work: broken/bug), I tried the “Validatorless Bootstrap” option from the
[Chef Documentation] (

and well… it worked. I should have tried this 7:45hrs ago.