Chef apt repo only has 0.9.8 for 10.04?


#1

I could have sworn it used to have 0.9.12. Was I hallucinating?

http://apt.opscode.com/dists/lucid/main/binary-amd64/Packages


Mark J. Reed markjreed@gmail.com


#2

OK, I wasn’t hallucinating, but I got it from sid, not lucid. NM.

On Fri, Jan 14, 2011 at 2:34 PM, Mark J. Reed markjreed@gmail.com wrote:

I could have sworn it used to have 0.9.12. Was I hallucinating?

http://apt.opscode.com/dists/lucid/main/binary-amd64/Packages


Mark J. Reed markjreed@gmail.com


Mark J. Reed markjreed@gmail.com


#3

0.9.12 hasn’t been pushed as it is considered insufficiently tested
with the open source server. Grab the newest version from the sid
repo if you require features or fixes > 0.9.8.

For bootstrapping you can edit the sources.list in the stock ubuntu-
apt erb template and drop it in .chef/bootstrap and knife will pick it
up.

We should probably push 0.9.12 - it’s been a good few months now.
Anyone able to report successes or failures with the open source server?

S.

On 14 Jan 2011, at 19:34, “Mark J. Reed” markjreed@gmail.com wrote:

I could have sworn it used to have 0.9.12. Was I hallucinating?

http://apt.opscode.com/dists/lucid/main/binary-amd64/Packages


Mark J. Reed markjreed@gmail.com


#4

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I actually just fixed this about an hour ago - 0.9.12 is in all debian and ubuntu components on our apt server. The exception is still maverick, per http://tickets.opscode.com/browse/CHEF-1976. We’ll get that updated sometime next week.

On Jan 14, 2011, at 11:45 AM, Stephen Nelson-Smith wrote:

0.9.12 hasn’t been pushed as it is considered insufficiently tested with the open source server. Grab the newest version from the sid repo if you require features or fixes > 0.9.8.

For bootstrapping you can edit the sources.list in the stock ubuntu-apt erb template and drop it in .chef/bootstrap and knife will pick it up.

We should probably push 0.9.12 - it’s been a good few months now. Anyone able to report successes or failures with the open source server?

S.

On 14 Jan 2011, at 19:34, “Mark J. Reed” markjreed@gmail.com wrote:

I could have sworn it used to have 0.9.12. Was I hallucinating?

http://apt.opscode.com/dists/lucid/main/binary-amd64/Packages


Mark J. Reed markjreed@gmail.com


Opscode, Inc
Joshua Timberman, Technical Evangelist
IRC, Skype, Twitter, Github: jtimberman

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (Darwin)

iEYEARECAAYFAk0w4fMACgkQO97WSdVpzT236wCeNau5pqaoA56VAI7mveJlIcS6
sUMAn2I3KdHic8m/PZhoLDgSwCGqiJlg
=Oicv
-----END PGP SIGNATURE-----