Chef-client --chef-license accept (InvalidOption), Windows 10

#1

When running a test-kitchen using 'kitchen converge' I receive the following result:

 Thank you for installing Chef Infra Client! For help getting started visit https://learn.chef.io
       Transferring files to <recent-centos1>
       +---------------------------------------------+
            Chef License Acceptance

       Before you can continue, 2 product licenses
       must be accepted. View the license at
       https://www.chef.io/end-user-license-agreement/

       Licenses that need accepting:
         * Chef Infra Client
         * Chef InSpec

       Do you accept the 2 product licenses (yes/no)?

However, the command line in Windows 10 does not allow me to input when this option arises.

I've also tried the 3 following steps:

STEP 1: Try accepting with chef-client with from latest CHEFDK package: https://downloads.chef.io/chefdk/stable

chef-client --version
Chef: 14.12.3

chef-client --chef-license accept
Traceback (most recent call last):
        7: from C:/opscode/chefdk/bin/chef-client:324:in `<main>'
        6: from C:/opscode/chefdk/bin/chef-client:324:in `load'
        5: from C:/opscode/chefdk/embedded/lib/ruby/gems/2.5.0/gems/chef-14.12.3-universal-mingw32/bin/chef-client:25:in `<top (required)>'
        4: from C:/opscode/chefdk/embedded/lib/ruby/gems/2.5.0/gems/chef-14.12.3-universal-mingw32/lib/chef/application.rb:64:in `run'
        3: from C:/opscode/chefdk/embedded/lib/ruby/gems/2.5.0/gems/chef-14.12.3-universal-mingw32/lib/chef/application/client.rb:313:in `reconfigure'
        2: from C:/opscode/chefdk/embedded/lib/ruby/gems/2.5.0/gems/chef-14.12.3-universal-mingw32/lib/chef/application.rb:55:in `reconfigure'
        1: from C:/opscode/chefdk/embedded/lib/ruby/gems/2.5.0/gems/chef-14.12.3-universal-mingw32/lib/chef/application.rb:96:in `configure_chef'
C:/opscode/chefdk/embedded/lib/ruby/gems/2.5.0/gems/mixlib-cli-2.0.3/lib/mixlib/cli.rb:230:in `parse_options': invalid option: --chef-license (OptionParser::InvalidOption)

STEP 2: Supplying environmental variable in System Properties

KEY: CHEF_LICENSE 
VALUE: accept

STEP 3: adding file to C:\Users{{USER}}.chef\accepted_licenses\inspec thats empty

None of these options worked. Am I missing something?

Thank you,

1 Like
Cannot accept chef-client license on bootstrapping
#2

https://discourse.chef.io/t/cannot-accept-chef-client-license-on-bootstrapping/15120/9

Solution was found here, in your kitchen.yml file, add the following settings if you download the latest stable branch for chefdk:

provisioner:
  name: chef_zero
  always_update_cookbooks: true
  product_version: 14
  client_rb:
    chef_license: accept
1 Like