Chef gem install knife-vsphere seems to install properly but chef gem list doent show it


I am a chef rookie but learning fairly quick. Was wanting to use the knife-vsphere plugin so I recently installed using… chef gem install knife-vsphere

The results are below. It appears to install fine. However when I try to determine if the plugin installed… it does not show.

This works on a window 7 box but not on a windows 10 box.

C:\Windows\system32>chef gem install knife-vsphere
Successfully installed netaddr-1.5.1
Successfully installed filesize-0.1.1
Successfully installed knife-vsphere-1.2.11
Parsing documentation for netaddr-1.5.1
Parsing documentation for filesize-0.1.1
Parsing documentation for knife-vsphere-1.2.11
Done installing documentation for netaddr, filesize, knife-vsphere after 2 seconds
3 gems installed

C:\Windows\system32>chef gem list knife*

*** LOCAL GEMS ***

knife-spork (1.6.1)
knife-windows (1.4.0)

I do see the gem file installed under

what am I doing wrong? Thanks in advance.

It looks like my issue is that I dont have the GEM_PATH setup properly for both chefdk up my local profile and the one installed in c:/opscode. On the working instance I have both…

    - C:/Users/lance_lyons/AppData/Local/chefdk/gem/ruby/2.1.0
    - C:/opscode/chefdk/embedded/lib/ruby/gems/2.1.0

On the instance that isnt working properly I only have one.

    - C:/opscode/chefdk/embedded/lib/ruby/gems/2.1.0

I have tried a few things to set via powershell but none of them are working including the one below.

PS C:\Windows\system32> $env:GEM_PATH = “$env:USERPROFILE\appdata\local\chefdk\gem\ruby\2.1.0;C:\opscode\chefdk\embedded\lib\ruby\gems\2.1.0”

Just figured out that during the chefdk install, the option to install environment customization’s was not selected. After rerunning the .msi and choosing to repair and install environment customization’s, the gem path is now set properly.