Chef-server-ctl reconfigure get Redis::CommandError ERR invalid password


#1

Hi,
I install chef-server-core-12.13.0-1.el6.x86_64.rpm into Red Hat 6 and I have followed the chef installation instruction.
When I tried to run step 4 “sudo chef-server-ctl reconfigure” from https://docs.chef.io/install_server.html and I got the following error:

Recipe: private-chef::redis_lb

  • runit_service[redis_lb] action restart

    • restart service runit_service[redis_lb]
  • template[/etc/opscode/logrotate.d/redis_lb] action create (up to date)

  • ruby_block[set_lb_redis_values] action create

    ================================================================================
    Error executing action create on resource ‘ruby_block[set_lb_redis_values]’

    Redis::CommandError

    ERR invalid password

    Cookbook Trace:

    /var/opt/opscode/local-mode-cache/cookbooks/private-chef/recipes/redis_lb.rb:119:in `block (2 levels) in from_file’

    Resource Declaration:

    In /var/opt/opscode/local-mode-cache/cookbooks/private-chef/recipes/redis_lb.rb

    104: ruby_block “set_lb_redis_values” do
    105: retries 5
    106: retry_delay 1
    107: only_if { is_data_master? }
    108: block do
    109: require "redis"
    110: redis = Redis.new(:host => redis_data.vip,
    111: :port => redis_data.port,
    112: :password => redis_data.password)
    113: xdl = node[‘private_chef’][‘lb’][‘xdl_defaults’]
    114: banned_ips = PrivateChef[‘banned_ips’]
    115: maint_mode_ips = PrivateChef[‘maint_mode_whitelist_ips’]
    116: # Ensure there is no stale data, but first institute
    117: # a brief maint mode to avoid potential misrouting when
    118: # we delete old keys.
    119: redis.hset “dl_default”, “503_mode”, true
    120: next while not redis.spop(“banned_ips”).nil?
    121: next while not redis.spop(“maint_data”).nil?
    122: keys = redis.hkeys "dl_default"
    123:
    124: # Clear all dl_default keys except for the 503 mode we just set.
    125: redis.pipelined do
    126: keys.each do |key|
    127: redis.hdel “dl_default”, key unless key == "503_mode"
    128: end
    129: end
    130:
    131: redis.pipelined do
    132: # Now we’re clear to repopulate from configuration.
    133: if (!banned_ips.nil?)
    134: banned_ips.each do |ip|
    135: redis.sadd “banned_ips”, ip
    136: end
    137: end
    138: if (!maint_mode_ips.nil?)
    139: maint_mode_ips.each do |ip|
    140: redis.sadd “maint_data”, ip
    141: end
    142: end
    143: # Note that we’ll preserve 503 mode until everything is
    144: # populated.
    145: if (!xdl.nil?)
    146: xdl.each do |key, value|
    147: redis.hset(“dl_default”, key, value) unless key == "503_mode"
    148: end
    149: end
    150: end

    Compiled Resource:

    Declared in /var/opt/opscode/local-mode-cache/cookbooks/private-chef/recipes/redis_lb.rb:104:in `from_file’

    ruby_block(“set_lb_redis_values”) do
    action [:create]
    retries 5
    retry_delay 1
    default_guard_interpreter :default
    block_name "set_lb_redis_values"
    declared_type :ruby_block
    cookbook_name "private-chef"
    recipe_name "redis_lb"
    block #Proc:0x00000008083ad8@/var/opt/opscode/local-mode-cache/cookbooks/private-chef/recipes/redis_lb.rb:108
    only_if { #code block }
    end

    Platform:

    x86_64-linux

Recipe: private-chef::opscode-solr4

  • runit_service[opscode-solr4] action restart
    • restart service runit_service[opscode-solr4]

Running handlers:
[2017-05-09T15:51:00-04:00] ERROR: Running exception handlers
Running handlers complete
[2017-05-09T15:51:00-04:00] ERROR: Exception handlers complete
Chef Client failed. 38 resources updated in 02 minutes 22 seconds
[2017-05-09T15:51:00-04:00] FATAL: Stacktrace dumped to /var/opt/opscode/local-mode-cache/chef-stacktrace.out
[2017-05-09T15:51:00-04:00] FATAL: Please provide the contents of the stacktrace.out file if you file a bug report
[2017-05-09T15:51:00-04:00] FATAL: Redis::CommandError: ruby_block[set_lb_redis_values] (private-chef::redis_lb line 104) had an error: Redis::CommandError: ERR invalid password

Please let me know what I need to do to fix this problem.

Thank you,
Hung le


#2

Can anyone help me to fix this problem?

Thank you


#3

I am getting same problem… Is your problem resolved?