Chef Server: missing pivotal.rb and pivotal.pem

Cloud: AWS
AMI: ami-3a229449 (ubuntu/images/hvm-ssd/ubuntu-vivid-15.04-amd64-server-20160203 - ami-3a229449
)
Chef Server Version: 12.4.1

Initial configuration:

/etc/hostname > somehost.xxx.xxx
/etc/hosts > 10.0.0.1 somehost.xxx.xxx

To install Chef server I run following commands:

sudo apt-get -y update
sudo apt-get dist-upgrade -y --force-yes

sudo wget https://web-dl.packagecloud.io/chef/stable/packages/ubuntu/trusty/chef-server-core_12.4.1-1_amd64.deb
sudo dpkg -i chef-server-core_*.deb

All go well, no error but when I try to register a new admin user:

sudo chef-server-ctl user-create admin admin admin admin@xx.xxx megapass --filename ~/.chef/chef-server-admin.pem

I get following error:

ERROR: CONFIGURATION ERROR:Specified config file /etc/opscode/pivotal.rb does not exist

If I run following command:

sudo chef-server-ctl reconfigure

I get error below:

Recipe: private-chef::default

  • directory[/etc/opscode] action create (up to date)
  • directory[/etc/opscode/logrotate.d] action create (up to date)
    [2016-02-06T19:35:12+00:00] FATAL:

BOOT007: The secrets file (/etc/opscode/private-chef-secrets.json) is present
but the file /etc/opscode/pivotal.pem is missing.

     Ensure that private-chef-secrets.json is copied into /etc/opscode from the
     first Chef Server node that you brought online, then run
     'chef-server-ctl reconfigure' again.

Could you please help me to identify what might be wrong? I know that Chef Server supported Ubuntu version is up to 14.04, but on internet I’ve seen a lot of manuals running on 15.04. Also couple months ago I was installing 12.2 on Ubuntu 15.04, but I might be wrong about Ubuntu version.

Also what Ubuntu versions are supported by latest Chef Server e.g. Ubuntu 14.10 ? 15.10?

Thank you.

Ok, the problem can be solve by:

sudo mkdir /usr/lib/systemd/system