Chef Server Setup in Chef Rally Example Fails


#1

I’m trying to work through the example here:
https://learn.chef.io/modules/manage-a-node-chef-server/ubuntu/bring-your-own-system/set-up-your-chef-server#/

and when I run the script:
/tmp/install-chef-server.sh

and when it gets near the end, it’s getting connection refused error:

Waiting for services…
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0curl: (7) Failed to connect to localhost port 8000: Connection refused

I’m installing the chef server on Ubuntu 16.04 on Virtualbox 5.2.6 and I’ve also tried the latest version of chef-server
chef-server-core_12.17.33-1_amd64.deb

and still gets the same error.


#2

Is there anything else currently listening on port 8000? What does ‘netstat -an | grep 8000’ say?


#3

There is nothing running on port 8000:

vagrant@ubuntu-xenial:~$ netstat -an | grep 8000

vagrant@ubuntu-xenial:~$

I have ran this setup script on two separate windows 10 (hosts) systems and multiple attempts on each system with the same result.


#4

Sorry folks, I figured out that the problem was not enough memory allocated to the VM. Only 1G by default is allocated so I increased it to 4G and gave it 2 CPU’s in the Vagrant file with this:
config.vm.provider “virtualbox” do |v|
v.memory = 4096
v.cpus = 2
end