ChefSpec 5.0 released


#1

ChefSpec 5.0 has been released to Rubygems and will be included in our next release of ChefDK.

What’s new:

  • Requires a minimum of Chef 12.0
  • Adds custom templating to Coverage Reporting. See readme for details
  • Adds matcher for apt_repository resource
  • Adds matcher for apt_update resource
  • Adds support for the :before notification
  • Allows stubbing encrypted databags loaded with data_bag_item
  • Adds Travis CI testing against Chef 12.8 - 12.13

-Tim