Connect Habitat to Automate

I have been working through the learn chef automate your infra deployments course and have a question regarding connecting to my local lab automate instance. I am using a self signed cert, and upon editing the Automate section of the default.toml file to connect to my Automate lab instance, I am getting an ssl error when running the chef-client on the node after uploading the new pkg to builder. I have tried adding an ssl_verify_mode "verify_none" lint to the Automate section in the default.toml, but that is obviously not the correct flag. can someone point me to the proper place to find the correct flag?

Hi! The ssl_verify_mode setting doesn't go under the [automate] table but rather on its own. This is because its not an automate setting but a chef-client setting.

ssl_verify_mode = ":verify_none"
1 Like

@greg.schofield, Thanks for the confirmation. I do have that line outside of the automate stanza. It was there initially in the code cloned for the lab. Not sure if I have something else configured incorrectly, or if this is just not working with Self signed certs on an automate/chef infra combo server.

Hi @byteflyer sorry I missed your message. If you join the Chef Community slack we can usually help you there much faster!