Deleting nodes via web ui -- doesn't reappear


#1

I have a chef client with a validation token.

I deleted the node via the web ui (just to see what would happen). I
also removed the registration for the node.

When the client connected again, I see a new validated registration in
the web ui, but the node doesn’t show up in the list, and I this shows
up in the chef server logs:

~ Started request handling: Sun Jun 28 02:07:40 +0000 2009
~ Params: {“format”=>nil, “action”=>“show”,
“id”=>“chefclient_localdomain”,
“controller”=>“chef_server_slice/nodes”}
~ Cannot load node chefclient.localdomain -
(Merb::ControllerExceptions::NotFound)

That’s not expected behavior, right?


#2

Did you try running the client again? if I remember correctly, the first
time it appeared in the registration screen, and the second one in the node
screen (if you don’t have the automatic validation configured, you’d need
two runs, so maybe chef-server isn’t that smart yet)


Albert Llop
Tech Department
albert@kingsofmambo.com

2009/6/28 Joe Van Dyk joe@fixieconsulting.com

I have a chef client with a validation token.

I deleted the node via the web ui (just to see what would happen). I
also removed the registration for the node.

When the client connected again, I see a new validated registration in
the web ui, but the node doesn’t show up in the list, and I this shows
up in the chef server logs:

~ Started request handling: Sun Jun 28 02:07:40 +0000 2009
~ Params: {“format”=>nil, “action”=>“show”,
“id”=>“chefclient_localdomain”,
“controller”=>“chef_server_slice/nodes”}
~ Cannot load node chefclient.localdomain -
(Merb::ControllerExceptions::NotFound)

That’s not expected behavior, right?