ERROR: Cookbook app_test not found


#1

Hello master Chefs,

I am testing a cookbook app_test with a Vagrant virtual box VM; when I do ‘vagrant up’ at the cookbook location, I get this message:

[2014-08-21T15:46:42-04:00] ERROR: Cookbook app_test not found. If you’re loading app_test from another cookbook, make sure you configure the dependency in your metadata

I notice that at the start of the run, vagrant sends this message:
[application_box] The cookbook path ‘/Users/luis.flores/chef_repo/cookbooks/app_test/cookbooks’ doesn’t exist. Ignoring…

My knife.rb states the cookbook path as …
cookbook_path “#{ENV[‘HOME’]}/chef_repo” # I have tried with “#{ENV[‘HOME’]}/chef_repo/cookbooks” with same result

As you can see, the last “/cookbooks” is being added in runtime, I have checked my Vagrantfile, metadata.rb and kitchen.yml and none has a cookbook path to add. I don’t know which component is adding that reference, all I know is the ‘knife.rb’ file should specify that value, so… What is happening?

Regards.

Luis Fernando Flores
+52 449 9107800 xt: 6241
Av. Eugenio Garza Sada #902
Parque Industrial Tecnopolo
Aguascalientes, Aguascalientes,
Mexico 20328