Error - Fatal: No Nodes returned from search

Hello, I'm currently attempting to deploy ArcGIS Enterprise 10.9.1 using Chef. I have the Chef Server (RHEL7) and Chef Workstation (Server 2019) configured. Everything was going somewhat smoothly until today when I attempted to start the install of ArcGIS on one of my VMs and I received a "FATAL: No nodes returned from search" error.

I didn't have any issues bootstrapping the VM and when I run 'knife node list' or 'knife client list' the node shows up. However, in Chef Manage it only shows under Administration > Group > Clients, not under the main section for Nodes or Clients. Also, I've uploaded some roles using the knife upload roles command even though the command completes without error, the roles do not appear in Chef manage. I uploaded the cookbooks with the knife upload command, but they do appear in Chef Manage.

I've tried running bootstrap on the VM again, but that doesn't change the error. At one point the disk on my Chef Server was full (I've since cleared it) and I'm wondering if that caused something to get corrupted. I've run chef-server-ctl reconfigure as well as chef-server-ctl reindex -a with no luck on resolving the error.

The client.rb file on the bootstrapped VM has the correct information and I can ping from the chef server to the chef workstation and the client.

Any ideas on what I could be doing wrong or what steps I can take to help troubleshoot and fix this issue?

The software versions I'm using:
Chef-Workstation 11.679
Chef Client 17.8.25
Chef Manage 3.2.13
Chef Server Core 14.11.15

The command I'm running that's resulting in the error:

knife winrm 'role:arcgis-portal-primary' 'chef-client' --winrm-shell elevated -x 'username' -P 'password'

Before running the above command I ran the following command (no errors were given after I ran the command)

knife node run_list set portal-active 'role[arcgis-portal-primary]'

We had some issues with that version of the client, can you try to regress back to chef client 17.5.22?

17.8.25 gave us a lot of issues in bootstrapping and with powershell.

~WRD0000.jpg

1 Like

For sure, I would be happy to try installing Chef Client 17.5.22. I just downloaded it so now I'll have to get 17.8.25 uninstalled. I'm assuming it's as simple as deleting the node/client from using Chef Manage then uninstalling the Chef Client. I'll find out soon enough.

1 Like

I installed Chef Client 17.5.22 and I'm still getting the No Nodes returned from search error. I've spent the last couple of days troubleshooting this. I'd like to think it was a problem resolving the hostname of Node, however I cannot find any proof that there's a problem with the hostname. Bootstrapping and even knife node list & knife client list all work fine. I can see the node in Chef Manage and all of its attributes look good. Even 'knife search node name:node' displays the node correctly. I have found that simply running "chef-client" on the node works. I ran "chef-client" with the node's run-list set to empty, and it ran without errors. However, the Chef Workstation still cannot execute a chef run (other than bootstrap) on that node because it says the node isn't found in the search.