Failing on bootstraping node


#1

Hello chefs,

When bootstraping a node I get the following.

$ knife bootstrap boobierack -x masterkorp --sudo -r "role[base]"
knifeBootstrapping Chef on boobierack
boobierack knife sudo password:
Enter your password:
boobierack
boobierack /usr/lib/ruby/vendor_ruby/mixlib/log.rb:97:in level=': Log level must be one of :debug, :info, :warn, :error, or :fatal (ArgumentError) boobierack from /usr/lib/ruby/vendor_ruby/chef/application.rb:113:inconfigure_logging’
boobierack from /usr/lib/ruby/vendor_ruby/chef/application/client.rb:213:in configure_logging' boobierack from /usr/lib/ruby/vendor_ruby/chef/application.rb:63:inreconfigure’
boobierack from /usr/lib/ruby/vendor_ruby/chef/application/client.rb:168:in reconfigure' boobierack from /usr/lib/ruby/vendor_ruby/chef/application.rb:68:inrun’
boobierack from /usr/bin/chef-client:25:in `’

When i got the node /etc/chef/client.rb
log_level :auto
log_location STDOUT
chef_server_url "myserverurl"
validation_client_name “chef-validator”

Using default node name (fqdn)

Why log_level goes to :auto ?? If i edit it to :info the bootstarp script makes it happen again.

I am using Chef 11.8.2


Regards,
Alfredo Palhares


#2

On Friday, January 31, 2014 at 9:48 AM, Alfredo Palhares wrote:

Hello chefs,

When bootstraping a node I get the following.

$ knife bootstrap boobierack -x masterkorp --sudo -r "role[base]"
knifeBootstrapping Chef on boobierack
boobierack knife sudo password:
Enter your password:
boobierack
boobierack /usr/lib/ruby/vendor_ruby/mixlib/log.rb:97:in level=': Log level must be one of :debug, :info, :warn, :error, or :fatal (ArgumentError) boobierack from /usr/lib/ruby/vendor_ruby/chef/application.rb:113:inconfigure_logging’
boobierack from /usr/lib/ruby/vendor_ruby/chef/application/client.rb:213:in configure_logging' boobierack from /usr/lib/ruby/vendor_ruby/chef/application.rb:63:inreconfigure’
boobierack from /usr/lib/ruby/vendor_ruby/chef/application/client.rb:168:in reconfigure' boobierack from /usr/lib/ruby/vendor_ruby/chef/application.rb:68:inrun’
boobierack from /usr/bin/chef-client:25:in `’

When i got the node /etc/chef/client.rb
log_level :auto
log_location STDOUT
chef_server_url "myserverurl"
validation_client_name “chef-validator”

Using default node name (fqdn)

Why log_level goes to :auto ?? If i edit it to :info the bootstarp script makes it happen again.

I am using Chef 11.8.2


Regards,
Alfredo Palhares

The target box has chef 10.something installed. Chef 11 supports an “auto” log level that attempts to do the right thing depending on whether you’re running chef manually in the console or not. Chef 10 doesn’t support this setting. You can either modify your bootstrap script to install chef 11.x or change the log level setting to :info (or whatever you like).


Daniel DeLeo