Help with building new version of zookeeper

Hello All,
I am trying to build a new version of core/zookeeper, 3.4.14, and I am running into dependency issues. I started with just bumping the version in the plan to 3.4.14 trying to rebuild with the most current version of the plan but the build is getting hung up on two deps within jre8. To see if this was unique to the new version I tried with the older version, 3.4.13, with the same results;

★ Install of core/jre8/8u162/20180409210549 complete with 0 new packages installed.
   zookeeper: Resolved dependency 'core/jre8/8u162/20180409210549' to /hab/pkgs/core/jre8/8u162/20180409210549
   zookeeper: WARN:
   zookeeper: WARN: The following runtime dependencies have more than one version
   zookeeper: WARN: release in the full dependency chain:
   zookeeper: WARN:
   zookeeper: WARN:   * core/glibc ( core/glibc/2.22/20170513201042 core/glibc/2.27/20190115002733 )
   zookeeper: WARN:   * core/linux-headers ( core/linux-headers/4.3/20170513200956 core/linux-headers/4.17.12/20190115002705 )

I checked out the post Base Plans Refresh is Coming! on pinning versions for your own origin but I am not sure if it applies here. I did try pinning the version to older ones in pkg_deps but it was still throwing the same long error.

My question is do I need to wait for the upcoming core refresh for this to be fixed? Do I need to write a wrapper for my pkg_deps to pin the version there? Am I missing something basic that would provide a simple solution? Are some docs I should get familiar with that would solve for this? Thanks for any feedback or ideas.

There’s an outstanding feature request for zookeeper for a way to issue correct id’s as well, beyond base plan refresh:

1 Like

Thanks for the link, that would be a nice fix to have in the core package. I have a hacky workaround where I do some binlinking with hab and chef for the config with the current 3.4.13 artifact in builder. Do you think will include a fix for the versioning? I thought this was a more generic issue, as in dep management with nested deps or am I missing something?

Hmm, I don’t have any issues building the latest zookeeper. It isn’t pinned to any version of JRE, so for me it picks up the latest ( core/jre8/8.192.0/20190115162808 ) and I don’t get any dep errors.

Try updating your habitat version (and local studio) and make sure there aren’t any version pins on the deps (so it looks like this) and it should build okay.

I was on hab 0.78 and updating to 0.82 looks to have fixed it? Not what I was expecting with those error messages, thanks for the tip @irvingpop!