JSON Dependency issue


#1

Greetings!

I have installed a brand new chef (11.4.0) with ryby 1.9.3
Although I see chef depends on json (<= 1.7.7, >= 1.4.4) and I have json (1.7.7),
when I run knife I get this error:

/Users/mic/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.3/lib/bundler/spec_set.rb:90:in `block in materialize’: Could not find json-1.6.1 in any of the sources (Bundler::GemNotFound)

The gist with the details can be found here :

Any ideas ?


#2

On Thursday, April 4, 2013 at 2:39 AM, Michael L. wrote:

Greetings!

I have installed a brand new chef (11.4.0) with ryby 1.9.3
Although I see chef depends on json (<= 1.7.7, >= 1.4.4) and I have json (1.7.7),
when I run knife I get this error:

/Users/mic/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.3/lib/bundler/spec_set.rb:90:in `block in materialize’: Could not find json-1.6.1 in any of the sources (Bundler::GemNotFound)

The gist with the details can be found here :

https://gist.github.com/anonymous/5309019

Any ideas ?
What’s in Gemfile.lock?


Daniel DeLeo