Knife cookbook upload internal server error

I've setup chef server 13.0.17 on CentOS 7 and chef workstation 0.9.42 on CentOS 7
While trying to upload cookbook from workstation to server, i'm facing below error,

meanwhile knife ssl fetch & knife ssl check works fine without any issues
any help would be much appreciated

Thanks,
Sarath

Hello Everyone,

  New to the list here, I am getting an error when I run my

chef-client on a node that I was testing a new cookbook on. I have
made sure to add the node correctly when I check the knife client
list it shows up properly. When I login to the ui I see it in
there with it appears everything properly in it's place.

This is from the node in question:

knife ssl check
WARNING: No knife configuration file found. See
for details.
Connecting to host localhost:443
ERROR: Network Error: Connection refused - connect(2) for
"localhost" port 443
Check your knife configuration and network settings

This is from the chef-workstation:

  knife client list

cfs-validator

  So I am not sure where to go from here. Any help would be much

appreciated.

This didn't come out right sorry

typically I don't think knife commands are used on the node itself, just chef-client commands. I get the same thing if I try on a server, but doing knife ssl check -s https://yourchefserverurl.com worked. The -s option is what it needs from a config file, which isn't present on the node except in /etc/chef/client.rb probably.