Knife ssh hang out whenn ssh is not present for a node


When we use to run Knife ssh to run chef-client on particular node and SSH is not enable for that node . Then Knife ssh get hang out.

Is there any solution to come out from hang state.


Did you try --ssh-timeout option ?


How long did you wait?

Most SSH client configurations have a very generous SSH timeout set. You might review your /etc/ssh/ssh-cient.config, or $HOME/.ssh/config settings.

Now, me? On hosts that are doing “knife ssh” a lot, I review such settings. I also set up $HOME/.ssh/config do disable the “known_hosts” file, so I get no errors about changing host keys. It’s particularly handy if you’re replacing hosts frequently in a small address space. The setup is described at