Knife ssh not working


#1

hi,

i am getting error for knife ssh command.

FATAL: 1 node found, but does not have the required attribute to establish
the connection. Try setting another attribute to open the connection using
–attribute.

please share the details for knife.rb

thanks,
K.Gopalakrishnan


#2

If your DNS is not fully configured for the node in question, you may need to use “-a ipaddress” in order to connect on that basis. I’ve run into that.

Nico Kadel-Garcia
Lead DevOps Engineer
nkadel@skyhookwireless.commailto:nkadel@skyhookwireless.com

From: kritivagop01 . [mailto:krithiva.gopal@gmail.com]
Sent: Monday, December 01, 2014 12:57 PM
To: chef@lists.opscode.com
Subject: [chef] knife ssh not working

hi,

i am getting error for knife ssh command.

FATAL: 1 node found, but does not have the required attribute to establish the connection. Try setting another attribute to open the connection using --attribute.

please share the details for knife.rb

thanks,
K.Gopalakrishnan


#3

hi,

i am able to search using :

[root@localhost chef-repo]# knife search 'name:newclient’
1 items found

Node Name: newclient
Environment: _default
FQDN: newclient.domain.com
IP: 192.168.142.152
Run List: recipe[push-jobs], recipe[snmp]
Roles:
Recipes: push-jobs, snmp, push-jobs::default, push-jobs::linux,
push-jobs::config, push-jobs::service, runit::default,
build-essential::default, build-essential::_rhel, snmp::default
Platform: centos 6.6
Tags:

[root@localhost chef-repo]# knife ssh “platform:centos 6.6” -a
192.168.142.152 "ls /tmp"
FATAL: 2 nodes found, but does not have the required attribute to establish
the connection. Try setting another attribute to open the connection using
–attribute.

dns setting is done and able to ping with that.

[root@localhost chef-repo]# ping newclient
PING newclient.domain.com (192.168.142.152) 56(84) bytes of data.
64 bytes from newclient.domain.com (192.168.142.152): icmp_seq=1 ttl=64
time=1.14 ms
64 bytes from newclient.domain.com (192.168.142.152): icmp_seq=2 ttl=64
time=0.339 ms
64 bytes from newclient.domain.com (192.168.142.152): icmp_seq=3 ttl=64
time=0.448 ms
64 bytes from newclient.domain.com (192.168.142.152): icmp_seq=4 ttl=64
time=0.396 ms

On Tue, Dec 2, 2014 at 3:34 AM, Nico Kadel-Garcia <
nkadel@skyhookwireless.com> wrote:

If your DNS is not fully configured for the node in question, you may
need to use “-a ipaddress” in order to connect on that basis. I’ve run into
that.

Nico Kadel-Garcia

Lead DevOps Engineer

nkadel@skyhookwireless.com

From: kritivagop01 . [mailto:krithiva.gopal@gmail.com]
Sent: Monday, December 01, 2014 12:57 PM
To: chef@lists.opscode.com
Subject: [chef] knife ssh not working

hi,

i am getting error for knife ssh command.

FATAL: 1 node found, but does not have the required attribute to establish
the connection. Try setting another attribute to open the connection using
–attribute.

please share the details for knife.rb

thanks,

K.Gopalakrishnan


#4

Use the actual string “-a ipaddress” (not substituting the IP address
of the box).

  • Julian

On Tue, Dec 2, 2014 at 1:13 AM, kritivagop01 . krithiva.gopal@gmail.com wrote:

hi,

i am able to search using :

[root@localhost chef-repo]# knife search 'name:newclient’
1 items found

Node Name: newclient
Environment: _default
FQDN: newclient.domain.com
IP: 192.168.142.152
Run List: recipe[push-jobs], recipe[snmp]
Roles:
Recipes: push-jobs, snmp, push-jobs::default, push-jobs::linux,
push-jobs::config, push-jobs::service, runit::default,
build-essential::default, build-essential::_rhel, snmp::default
Platform: centos 6.6
Tags:

[root@localhost chef-repo]# knife ssh “platform:centos 6.6” -a
192.168.142.152 "ls /tmp"
FATAL: 2 nodes found, but does not have the required attribute to establish
the connection. Try setting another attribute to open the connection using
–attribute.

dns setting is done and able to ping with that.

[root@localhost chef-repo]# ping newclient
PING newclient.domain.com (192.168.142.152) 56(84) bytes of data.
64 bytes from newclient.domain.com (192.168.142.152): icmp_seq=1 ttl=64
time=1.14 ms
64 bytes from newclient.domain.com (192.168.142.152): icmp_seq=2 ttl=64
time=0.339 ms
64 bytes from newclient.domain.com (192.168.142.152): icmp_seq=3 ttl=64
time=0.448 ms
64 bytes from newclient.domain.com (192.168.142.152): icmp_seq=4 ttl=64
time=0.396 ms

On Tue, Dec 2, 2014 at 3:34 AM, Nico Kadel-Garcia
nkadel@skyhookwireless.com wrote:

If your DNS is not fully configured for the node in question, you may
need to use “-a ipaddress” in order to connect on that basis. I’ve run into
that.

Nico Kadel-Garcia

Lead DevOps Engineer

nkadel@skyhookwireless.com

From: kritivagop01 . [mailto:krithiva.gopal@gmail.com]
Sent: Monday, December 01, 2014 12:57 PM
To: chef@lists.opscode.com
Subject: [chef] knife ssh not working

hi,

i am getting error for knife ssh command.

FATAL: 1 node found, but does not have the required attribute to establish
the connection. Try setting another attribute to open the connection using
–attribute.

please share the details for knife.rb

thanks,

K.Gopalakrishnan


[ Julian C. Dunn jdunn@aquezada.com * Sorry, I’m ]
[ WWW: http://www.aquezada.com/staff/julian * only Web 1.0 ]
[ gopher://sdf.org/1/users/keymaker/ * compliant! ]
[ PGP: 91B3 7A9D 683C 7C16 715F 442C 6065 D533 FDC2 05B9 ]


#5

thanks ,

it is working fine now with -a ipaddress.

rgs
K.Gopalakrishnan

On Tue, Dec 2, 2014 at 1:01 PM, Julian C. Dunn jdunn@aquezada.com wrote:

Use the actual string “-a ipaddress” (not substituting the IP address
of the box).

  • Julian

On Tue, Dec 2, 2014 at 1:13 AM, kritivagop01 . krithiva.gopal@gmail.com
wrote:

hi,

i am able to search using :

[root@localhost chef-repo]# knife search 'name:newclient’
1 items found

Node Name: newclient
Environment: _default
FQDN: newclient.domain.com
IP: 192.168.142.152
Run List: recipe[push-jobs], recipe[snmp]
Roles:
Recipes: push-jobs, snmp, push-jobs::default, push-jobs::linux,
push-jobs::config, push-jobs::service, runit::default,
build-essential::default, build-essential::_rhel, snmp::default
Platform: centos 6.6
Tags:

[root@localhost chef-repo]# knife ssh “platform:centos 6.6” -a
192.168.142.152 "ls /tmp"
FATAL: 2 nodes found, but does not have the required attribute to
establish
the connection. Try setting another attribute to open the connection
using
–attribute.

dns setting is done and able to ping with that.

[root@localhost chef-repo]# ping newclient
PING newclient.domain.com (192.168.142.152) 56(84) bytes of data.
64 bytes from newclient.domain.com (192.168.142.152): icmp_seq=1 ttl=64
time=1.14 ms
64 bytes from newclient.domain.com (192.168.142.152): icmp_seq=2 ttl=64
time=0.339 ms
64 bytes from newclient.domain.com (192.168.142.152): icmp_seq=3 ttl=64
time=0.448 ms
64 bytes from newclient.domain.com (192.168.142.152): icmp_seq=4 ttl=64
time=0.396 ms

On Tue, Dec 2, 2014 at 3:34 AM, Nico Kadel-Garcia
nkadel@skyhookwireless.com wrote:

If your DNS is not fully configured for the node in question, you may
need to use “-a ipaddress” in order to connect on that basis. I’ve run
into

that.

Nico Kadel-Garcia

Lead DevOps Engineer

nkadel@skyhookwireless.com

From: kritivagop01 . [mailto:krithiva.gopal@gmail.com]
Sent: Monday, December 01, 2014 12:57 PM
To: chef@lists.opscode.com
Subject: [chef] knife ssh not working

hi,

i am getting error for knife ssh command.

FATAL: 1 node found, but does not have the required attribute to
establish

the connection. Try setting another attribute to open the connection
using

–attribute.

please share the details for knife.rb

thanks,

K.Gopalakrishnan


[ Julian C. Dunn jdunn@aquezada.com * Sorry, I’m ]
[ WWW: http://www.aquezada.com/staff/julian * only Web 1.0 ]
[ gopher://sdf.org/1/users/keymaker/ * compliant! ]
[ PGP: 91B3 7A9D 683C 7C16 715F 442C 6065 D533 FDC2 05B9 ]


#6

Hi,
what’s the output of knife node show ?
it’s very likely that fields like FQDN, ip are blank. Have you run
chef-client atleast once on the node(s).? are you running chef-client
with override option.? (chef-client -o “recipe[foo]”) . override option
doesn’t do node.save.

Regards
Santhosh
On 01/12/14 11:27 pm, kritivagop01 . wrote:

hi,

i am getting error for knife ssh command.

FATAL: 1 node found, but does not have the required attribute to
establish the connection. Try setting another attribute to open the
connection using --attribute.

please share the details for knife.rb

thanks,
K.Gopalakrishnan


#7

Try this:

knife ssh “platform:xenserver” -a ipaddress “ls /tmp”

On Mon, Dec 1, 2014 at 4:25 PM, Santhosh santhoshsusbs@gmail.com wrote:

Hi,
what’s the output of knife node show ?
it’s very likely that fields like FQDN, ip are blank. Have you run
chef-client atleast once on the node(s).? are you running chef-client with
override option.? (chef-client -o “recipe[foo]”) . override option doesn’t
do node.save.

Regards
Santhosh

On 01/12/14 11:27 pm, kritivagop01 . wrote:

hi,

i am getting error for knife ssh command.

FATAL: 1 node found, but does not have the required attribute to
establish the connection. Try setting another attribute to open the
connection using --attribute.

please share the details for knife.rb

thanks,
K.Gopalakrishnan


– Tiago Cruz