Launching Windows instances with chef-provisioning-aws


#1

I’m attempting to launch a windows instance into vpc but for some reason it
always picks ubuntu-trusty-14.04-amd64-server-20140816 (ami-73717d36)
instead of the ami I specified with :image_id => 'ami-xxxxxxxx' in the
bootstrap options. Any ideas on how to get my ami choice honored?


#2

It looks like you might be getting the default AMI for whatever region
you’re in.[1] For… reasons?

Try setting image_id as a machine option rather than a bootstrap option.

with_machine_options({

:bootstrap_options => {
:foo => “bar”
},
:image_id => “ami-73717d36”
})

[1]

On Fri, Jan 30, 2015 at 12:31 PM, tayworm . tayworm@gmail.com wrote:

I’m attempting to launch a windows instance into vpc but for some reason
it always picks ubuntu-trusty-14.04-amd64-server-20140816 (ami-73717d36)
instead of the ami I specified with :image_id => 'ami-xxxxxxxx' in the
bootstrap options. Any ideas on how to get my ami choice honored?


#3

This is what I got:

:image_id => ‘ami-de51669b’, [2015-01-30T18:30:34-07:00] ERROR: undefined
method `with_machine_options’ for Chef::Resource::Machine

with_machine_options({
:image_id => ‘ami-de51889b’,
:bootstrap_options => {
:key_name => ‘key’,
:instance_type => ‘m3.medium’,
:subnet => ‘subnet-93fb453b’
}})

Is there something painfully obvious that I’m missing here?

On Fri, Jan 30, 2015 at 4:56 PM, George Miranda gmiranda@getchef.com
wrote:

It looks like you might be getting the default AMI for whatever region
you’re in.[1] For… reasons?

Try setting image_id as a machine option rather than a bootstrap option.

with_machine_options({

:bootstrap_options => {
:foo => “bar”
},
:image_id => “ami-73717d36”
})

[1]
https://github.com/chef/chef-provisioning-aws/blob/master/lib/chef/provisioning/aws_driver/driver.rb#L270

On Fri, Jan 30, 2015 at 12:31 PM, tayworm . tayworm@gmail.com wrote:

I’m attempting to launch a windows instance into vpc but for some reason
it always picks ubuntu-trusty-14.04-amd64-server-20140816 (ami-73717d36)
instead of the ami I specified with :image_id => 'ami-xxxxxxxx' in the
bootstrap options. Any ideas on how to get my ami choice honored?


#4

To answer my own question, it looks like the syntax should be like this:

machine_options({
:image_id => ‘ami-de51889b’,
:bootstrap_options => {
:key_name => ‘key’,
:instance_type => ‘m3.medium’,
:subnet => ‘subnet-93fb453b’
}})

On Fri, Jan 30, 2015 at 6:34 PM, tayworm . tayworm@gmail.com wrote:

This is what I got:

:image_id => ‘ami-de51669b’, [2015-01-30T18:30:34-07:00] ERROR: undefined
method `with_machine_options’ for Chef::Resource::Machine

with_machine_options({
:image_id => ‘ami-de51889b’,
:bootstrap_options => {
:key_name => ‘key’,
:instance_type => ‘m3.medium’,
:subnet => ‘subnet-93fb453b’
}})

Is there something painfully obvious that I’m missing here?

On Fri, Jan 30, 2015 at 4:56 PM, George Miranda gmiranda@getchef.com
wrote:

It looks like you might be getting the default AMI for whatever region
you’re in.[1] For… reasons?

Try setting image_id as a machine option rather than a bootstrap option.

with_machine_options({

:bootstrap_options => {
:foo => “bar”
},
:image_id => “ami-73717d36”
})

[1]
https://github.com/chef/chef-provisioning-aws/blob/master/lib/chef/provisioning/aws_driver/driver.rb#L270

On Fri, Jan 30, 2015 at 12:31 PM, tayworm . tayworm@gmail.com wrote:

I’m attempting to launch a windows instance into vpc but for some reason
it always picks ubuntu-trusty-14.04-amd64-server-20140816 (ami-73717d36)
instead of the ami I specified with :image_id => 'ami-xxxxxxxx' in the
bootstrap options. Any ideas on how to get my ami choice honored?


#5

So now that that is solved, the next step is to get connected to the box. I
know the username and password for this ami, I just need to figure out how
to specify those, and also force chef-provisioning to use winrm instead of
ssh! Any pointers for me?

On Fri, Jan 30, 2015 at 6:38 PM, tayworm . tayworm@gmail.com wrote:

To answer my own question, it looks like the syntax should be like this:

machine_options({
:image_id => ‘ami-de51889b’,
:bootstrap_options => {
:key_name => ‘key’,
:instance_type => ‘m3.medium’,
:subnet => ‘subnet-93fb453b’
}})

On Fri, Jan 30, 2015 at 6:34 PM, tayworm . tayworm@gmail.com wrote:

This is what I got:

:image_id => ‘ami-de51669b’, [2015-01-30T18:30:34-07:00] ERROR: undefined
method `with_machine_options’ for Chef::Resource::Machine

with_machine_options({
:image_id => ‘ami-de51889b’,
:bootstrap_options => {
:key_name => ‘key’,
:instance_type => ‘m3.medium’,
:subnet => ‘subnet-93fb453b’
}})

Is there something painfully obvious that I’m missing here?

On Fri, Jan 30, 2015 at 4:56 PM, George Miranda gmiranda@getchef.com
wrote:

It looks like you might be getting the default AMI for whatever region
you’re in.[1] For… reasons?

Try setting image_id as a machine option rather than a bootstrap option.

with_machine_options({

:bootstrap_options => {
:foo => “bar”
},
:image_id => “ami-73717d36”
})

[1]
https://github.com/chef/chef-provisioning-aws/blob/master/lib/chef/provisioning/aws_driver/driver.rb#L270

On Fri, Jan 30, 2015 at 12:31 PM, tayworm . tayworm@gmail.com wrote:

I’m attempting to launch a windows instance into vpc but for some
reason it always picks ubuntu-trusty-14.04-amd64-server-20140816
(ami-73717d36) instead of the ami I specified with :image_id => 'ami-xxxxxxxx' in the bootstrap options. Any ideas on how to get my ami
choice honored?