LDAP integration with Chef


#1

Hello Chef,

I am working on integrating the Chef with LDAP but it is not working.

Added following lines under
/opt/opscode/embedded/cookbooks/private-chef/attributes/default.rb file,

default[‘private_chef’][‘ldap’][‘host’] = ''
default[‘private_chef’][‘ldap’][‘bind_dn’] = ''
default[‘private_chef’][‘ldap’][‘bind_password’] = ''
default[‘private_chef’][‘ldap’][‘base_dn’] = '
default[‘private_chef’][‘ldap’][‘system_adjective’] = ‘corporate’

private-chef-ctl reconfigure.

What i am missing here?

Thanks,
Trim


#2

Hey Trim,

You shouldn’t need to add all of those values in the embedded cookbooks.
There are a number of settings that can be put in the
private-chef.rb/chef-server.rb file to make this work.

See the docs here: https://docs.getchef.com/server_ldap.html

Note that you need either an Enterprise Chef 11 release or Chef 12 for
this to work. And as of this moment LDAP doesn’t work in the latest Chef
12 RC4. This will be fixed in the next RC.

Thanks,

Mark Mzyk

Trimurtulu k mailto:ktrimu@gmail.com
October 14, 2014 at 12:29 PM
Hello Chef,

I am working on integrating the Chef with LDAP but it is not working.

Added following lines under
/opt/opscode/embedded/cookbooks/private-chef/attributes/default.rb file,

default[‘private_chef’][‘ldap’][‘host’] = ''
default[‘private_chef’][‘ldap’][‘bind_dn’] = ''
default[‘private_chef’][‘ldap’][‘bind_password’] = ''
default[‘private_chef’][‘ldap’][‘base_dn’] = '
default[‘private_chef’][‘ldap’][‘system_adjective’] = ‘corporate’

private-chef-ctl reconfigure.

What i am missing here?

Thanks,
Trim