Open source chef client error


#1

Hey all,

I’m attempting to configure chef client on my chef server and running into
an error.

[root@chef:~] #knife configure --initial
/usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:247:in to_specs': Could not find chef (>= 0) amongst [bunny-0.8.0, erubis-2.7.0, highline-1.6.15, ipaddress-0.8.0, json-1.7.5, mime-types-1.19, mixlib-authentication-1.3.0, mixlib-cli-1.3.0, mixlib-config-1.1.2, mixlib-log-1.4.1, mixlib-shellout-1.1.0, moneta-0.7.1, net-ssh-2.6.5, net-ssh-gateway-1.1.0, net-ssh-multi-1.1, ohai-6.14.0, polyglot-0.3.3, rest-client-1.6.7, systemu-2.5.2, treetop-1.4.12, uuidtools-2.1.3, yajl-ruby-1.1.0] (Gem::LoadError) from /usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:256:into_spec’
from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1231:in `gem’
from /usr/local/bin/knife:18

I am running chef 11.8.0 under ubuntu 13.10.

Can anyone provide some insight on how to get around this error?

Thanks!
Tim


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B


#2

how you have installed chef? may be GEM_PATH/GEM_HOME is messed up. do you
have multiple ruby installation ?

On Tue, Dec 3, 2013 at 3:52 PM, Tim Dunphy bluethundr@gmail.com wrote:

Hey all,

I’m attempting to configure chef client on my chef server and running into
an error.

[root@chef:~] #knife configure --initial
/usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:247:in to_specs': Could not find chef (>= 0) amongst [bunny-0.8.0, erubis-2.7.0, highline-1.6.15, ipaddress-0.8.0, json-1.7.5, mime-types-1.19, mixlib-authentication-1.3.0, mixlib-cli-1.3.0, mixlib-config-1.1.2, mixlib-log-1.4.1, mixlib-shellout-1.1.0, moneta-0.7.1, net-ssh-2.6.5, net-ssh-gateway-1.1.0, net-ssh-multi-1.1, ohai-6.14.0, polyglot-0.3.3, rest-client-1.6.7, systemu-2.5.2, treetop-1.4.12, uuidtools-2.1.3, yajl-ruby-1.1.0] (Gem::LoadError) from /usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:256:into_spec’
from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1231:in `gem’
from /usr/local/bin/knife:18

I am running chef 11.8.0 under ubuntu 13.10.

Can anyone provide some insight on how to get around this error?

Thanks!
Tim


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B


#3

how you have installed chef? may be GEM_PATH/GEM_HOME is messed up. do you
have multiple ruby installation ?

Hi and thanks for your response. I did a gem install. And I actually didn’t
have those variable set. So I tried setting them, and I did make a little
progress.

[root@chef:~] #echo $GEM_HOME
/usr/lib/ruby/vendor_ruby/1.8

[root@chef:~] #echo $GEM_PATH
/usr/lib/ruby/vendor_ruby/1.8/rubygems

But now I am getting a different error, so I may not have the correct
values there:

[root@chef:~] #knife configure --initial
/usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:247:in to_specs': Could not find chef (>= 0) amongst [] (Gem::LoadError) from /usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:256:into_spec’
from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1231:in `gem’
from /usr/local/bin/knife:1

Do you think you could point me in the right direction in setting these
variables? I think that might solve the problem.

Tim

On Tue, Dec 3, 2013 at 6:56 PM, Ranjib Dey dey.ranjib@gmail.com wrote:

how you have installed chef? may be GEM_PATH/GEM_HOME is messed up. do you
have multiple ruby installation ?

On Tue, Dec 3, 2013 at 3:52 PM, Tim Dunphy bluethundr@gmail.com wrote:

Hey all,

I’m attempting to configure chef client on my chef server and running
into an error.

[root@chef:~] #knife configure --initial
/usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:247:in to_specs': Could not find chef (>= 0) amongst [bunny-0.8.0, erubis-2.7.0, highline-1.6.15, ipaddress-0.8.0, json-1.7.5, mime-types-1.19, mixlib-authentication-1.3.0, mixlib-cli-1.3.0, mixlib-config-1.1.2, mixlib-log-1.4.1, mixlib-shellout-1.1.0, moneta-0.7.1, net-ssh-2.6.5, net-ssh-gateway-1.1.0, net-ssh-multi-1.1, ohai-6.14.0, polyglot-0.3.3, rest-client-1.6.7, systemu-2.5.2, treetop-1.4.12, uuidtools-2.1.3, yajl-ruby-1.1.0] (Gem::LoadError) from /usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:256:into_spec’
from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1231:in `gem’
from /usr/local/bin/knife:18

I am running chef 11.8.0 under ubuntu 13.10.

Can anyone provide some insight on how to get around this error?

Thanks!
Tim


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B


#4

use omnibus. for the time being on ubuntu 13.10 64-bit do this:

wget ‘https://www.opscode.com/chef/download?v=&prerelease=false&p=ubuntu&pv=13.04&m=x86_64’ -O /tmp/chef.deb && sudo dpkg -i /tmp/chef.deb

you want to get rid of /usr/local/bin/{knife,chef-client} and other chef binaries.

you probably want to ‘/usr/local/bin/gem uninstall chef’ and ‘/usr/bin/gem uninstall chef’

you also should not be using ruby 1.8 and should remove those packages from your system and replace them with the ruby 1.9 ones. you don’t need the system ruby at all to run omnibus chef,
so if nothing else depends on ruby, then don’t have it installed, which will reduce confusion.

On 12/3/13 3:52 PM, Tim Dunphy wrote:

Hey all,

I’m attempting to configure chef client on my chef server and running
into an error.

[root@chef:~] #knife configure --initial
/usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:247:in
to_specs': Could not find chef (>= 0) amongst [bunny-0.8.0, erubis-2.7.0, highline-1.6.15, ipaddress-0.8.0, json-1.7.5, mime-types-1.19, mixlib-authentication-1.3.0, mixlib-cli-1.3.0, mixlib-config-1.1.2, mixlib-log-1.4.1, mixlib-shellout-1.1.0, moneta-0.7.1, net-ssh-2.6.5, net-ssh-gateway-1.1.0, net-ssh-multi-1.1, ohai-6.14.0, polyglot-0.3.3, rest-client-1.6.7, systemu-2.5.2, treetop-1.4.12, uuidtools-2.1.3, yajl-ruby-1.1.0] (Gem::LoadError) from /usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:256:into_spec’
from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1231:in `gem’
from /usr/local/bin/knife:18

I am running chef 11.8.0 under ubuntu 13.10.

Can anyone provide some insight on how to get around this error?

Thanks!
Tim


GPG me!!

gpg --keyserver pool.sks-keyservers.net
http://pool.sks-keyservers.net --recv-keys F186197B


#5

I’d strongly encourage you to try an omnibus install if at all possible.
It’s been a while since I tried it, but even Chef 10 did not work smoothly
with ruby 1.8.

http://www.opscode.com/chef/install/

Your life will be much simpler if chef has it’s own version of ruby and
dependencies installed.

On Tue, Dec 3, 2013 at 4:14 PM, Tim Dunphy bluethundr@gmail.com wrote:

how you have installed chef? may be GEM_PATH/GEM_HOME is messed up. do you

have multiple ruby installation ?

Hi and thanks for your response. I did a gem install. And I actually
didn’t have those variable set. So I tried setting them, and I did make a
little progress.

[root@chef:~] #echo $GEM_HOME
/usr/lib/ruby/vendor_ruby/1.8

[root@chef:~] #echo $GEM_PATH
/usr/lib/ruby/vendor_ruby/1.8/rubygems

But now I am getting a different error, so I may not have the correct
values there:

[root@chef:~] #knife configure --initial
/usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:247:in to_specs': Could not find chef (>= 0) amongst [] (Gem::LoadError) from /usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:256:into_spec’
from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1231:in `gem’
from /usr/local/bin/knife:1

Do you think you could point me in the right direction in setting these
variables? I think that might solve the problem.

Tim

On Tue, Dec 3, 2013 at 6:56 PM, Ranjib Dey dey.ranjib@gmail.com wrote:

how you have installed chef? may be GEM_PATH/GEM_HOME is messed up. do
you have multiple ruby installation ?

On Tue, Dec 3, 2013 at 3:52 PM, Tim Dunphy bluethundr@gmail.com wrote:

Hey all,

I’m attempting to configure chef client on my chef server and running
into an error.

[root@chef:~] #knife configure --initial
/usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:247:in to_specs': Could not find chef (>= 0) amongst [bunny-0.8.0, erubis-2.7.0, highline-1.6.15, ipaddress-0.8.0, json-1.7.5, mime-types-1.19, mixlib-authentication-1.3.0, mixlib-cli-1.3.0, mixlib-config-1.1.2, mixlib-log-1.4.1, mixlib-shellout-1.1.0, moneta-0.7.1, net-ssh-2.6.5, net-ssh-gateway-1.1.0, net-ssh-multi-1.1, ohai-6.14.0, polyglot-0.3.3, rest-client-1.6.7, systemu-2.5.2, treetop-1.4.12, uuidtools-2.1.3, yajl-ruby-1.1.0] (Gem::LoadError) from /usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:256:into_spec’
from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1231:in `gem’
from /usr/local/bin/knife:18

I am running chef 11.8.0 under ubuntu 13.10.

Can anyone provide some insight on how to get around this error?

Thanks!
Tim


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B


#6

you also should not be using ruby 1.8 and should remove those packages
from your system and replace them with the ruby 1.9 ones.

Sounds like good advice. Could you perhaps recommend a safe way to
uninstall ruby 1.8 without muffing up ruby 1.9?

Thanks
Tim

On Tue, Dec 3, 2013 at 7:22 PM, Booker Bense bbense@gmail.com wrote:

I’d strongly encourage you to try an omnibus install if at all possible.
It’s been a while since I tried it, but even Chef 10 did not work smoothly
with ruby 1.8.

http://www.opscode.com/chef/install/

Your life will be much simpler if chef has it’s own version of ruby and
dependencies installed.

On Tue, Dec 3, 2013 at 4:14 PM, Tim Dunphy bluethundr@gmail.com wrote:

how you have installed chef? may be GEM_PATH/GEM_HOME is messed up. do

you have multiple ruby installation ?

Hi and thanks for your response. I did a gem install. And I actually
didn’t have those variable set. So I tried setting them, and I did make a
little progress.

[root@chef:~] #echo $GEM_HOME
/usr/lib/ruby/vendor_ruby/1.8

[root@chef:~] #echo $GEM_PATH
/usr/lib/ruby/vendor_ruby/1.8/rubygems

But now I am getting a different error, so I may not have the correct
values there:

[root@chef:~] #knife configure --initial
/usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:247:in to_specs': Could not find chef (>= 0) amongst [] (Gem::LoadError) from /usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:256:into_spec’
from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1231:in `gem’
from /usr/local/bin/knife:1

Do you think you could point me in the right direction in setting these
variables? I think that might solve the problem.

Tim

On Tue, Dec 3, 2013 at 6:56 PM, Ranjib Dey dey.ranjib@gmail.com wrote:

how you have installed chef? may be GEM_PATH/GEM_HOME is messed up. do
you have multiple ruby installation ?

On Tue, Dec 3, 2013 at 3:52 PM, Tim Dunphy bluethundr@gmail.com wrote:

Hey all,

I’m attempting to configure chef client on my chef server and running
into an error.

[root@chef:~] #knife configure --initial
/usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:247:in to_specs': Could not find chef (>= 0) amongst [bunny-0.8.0, erubis-2.7.0, highline-1.6.15, ipaddress-0.8.0, json-1.7.5, mime-types-1.19, mixlib-authentication-1.3.0, mixlib-cli-1.3.0, mixlib-config-1.1.2, mixlib-log-1.4.1, mixlib-shellout-1.1.0, moneta-0.7.1, net-ssh-2.6.5, net-ssh-gateway-1.1.0, net-ssh-multi-1.1, ohai-6.14.0, polyglot-0.3.3, rest-client-1.6.7, systemu-2.5.2, treetop-1.4.12, uuidtools-2.1.3, yajl-ruby-1.1.0] (Gem::LoadError) from /usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:256:into_spec’
from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1231:in `gem’
from /usr/local/bin/knife:18

I am running chef 11.8.0 under ubuntu 13.10.

Can anyone provide some insight on how to get around this error?

Thanks!
Tim


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B


#7

You can remove ruby all together and then install 1.9; however, if you don’t want to break anything, I would suggest using RVM (allows you to have multiple ruby instances and set the running version). It’s nice bc you can switch easily and you can disable RVM and use the system default

Thanks,

Nikhil Shah

On Dec 3, 2013, at 9:07 PM, Tim Dunphy bluethundr@gmail.com wrote:

you also should not be using ruby 1.8 and should remove those packages from your system and replace them with the ruby 1.9 ones.

Sounds like good advice. Could you perhaps recommend a safe way to uninstall ruby 1.8 without muffing up ruby 1.9?

Thanks
Tim

On Tue, Dec 3, 2013 at 7:22 PM, Booker Bense bbense@gmail.com wrote:
I’d strongly encourage you to try an omnibus install if at all possible. It’s been a while since I tried it, but even Chef 10 did not work smoothly with ruby 1.8.

http://www.opscode.com/chef/install/

Your life will be much simpler if chef has it’s own version of ruby and dependencies installed.

On Tue, Dec 3, 2013 at 4:14 PM, Tim Dunphy bluethundr@gmail.com wrote:

how you have installed chef? may be GEM_PATH/GEM_HOME is messed up. do you have multiple ruby installation ?

Hi and thanks for your response. I did a gem install. And I actually didn’t have those variable set. So I tried setting them, and I did make a little progress.

[root@chef:~] #echo $GEM_HOME
/usr/lib/ruby/vendor_ruby/1.8

[root@chef:~] #echo $GEM_PATH
/usr/lib/ruby/vendor_ruby/1.8/rubygems

But now I am getting a different error, so I may not have the correct values there:

[root@chef:~] #knife configure --initial
/usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:247:in to_specs': Could not find chef (>= 0) amongst [] (Gem::LoadError) from /usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:256:into_spec’
from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1231:in `gem’
from /usr/local/bin/knife:1

Do you think you could point me in the right direction in setting these variables? I think that might solve the problem.

Tim

On Tue, Dec 3, 2013 at 6:56 PM, Ranjib Dey dey.ranjib@gmail.com wrote:
how you have installed chef? may be GEM_PATH/GEM_HOME is messed up. do you have multiple ruby installation ?

On Tue, Dec 3, 2013 at 3:52 PM, Tim Dunphy bluethundr@gmail.com wrote:
Hey all,

I’m attempting to configure chef client on my chef server and running into an error.

[root@chef:~] #knife configure --initial
/usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:247:in to_specs': Could not find chef (>= 0) amongst [bunny-0.8.0, erubis-2.7.0, highline-1.6.15, ipaddress-0.8.0, json-1.7.5, mime-types-1.19, mixlib-authentication-1.3.0, mixlib-cli-1.3.0, mixlib-config-1.1.2, mixlib-log-1.4.1, mixlib-shellout-1.1.0, moneta-0.7.1, net-ssh-2.6.5, net-ssh-gateway-1.1.0, net-ssh-multi-1.1, ohai-6.14.0, polyglot-0.3.3, rest-client-1.6.7, systemu-2.5.2, treetop-1.4.12, uuidtools-2.1.3, yajl-ruby-1.1.0] (Gem::LoadError) from /usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:256:into_spec’
from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1231:in `gem’
from /usr/local/bin/knife:18

I am running chef 11.8.0 under ubuntu 13.10.

Can anyone provide some insight on how to get around this error?

Thanks!
Tim


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B


#8

I would actually recommend rbenv or chruby over RVM. RVM is very
invasive, sets a bunch of environment variables that mess with Chef,
and you generally don’t need the overhead unless you’re a hardcore
Ruby developer working with multiple gemsets.

  • Julian

On Tue, Dec 3, 2013 at 9:54 PM, Nikhil Shah nshah@theorchard.com wrote:

You can remove ruby all together and then install 1.9; however, if you don’t
want to break anything, I would suggest using RVM (allows you to have
multiple ruby instances and set the running version). It’s nice bc you can
switch easily and you can disable RVM and use the system default

Thanks,

Nikhil Shah

On Dec 3, 2013, at 9:07 PM, Tim Dunphy bluethundr@gmail.com wrote:

you also should not be using ruby 1.8 and should remove those packages
from your system and replace them with the ruby 1.9 ones.

Sounds like good advice. Could you perhaps recommend a safe way to uninstall
ruby 1.8 without muffing up ruby 1.9?

Thanks
Tim

On Tue, Dec 3, 2013 at 7:22 PM, Booker Bense bbense@gmail.com wrote:

I’d strongly encourage you to try an omnibus install if at all possible.
It’s been a while since I tried it, but even Chef 10 did not work smoothly
with ruby 1.8.

http://www.opscode.com/chef/install/

Your life will be much simpler if chef has it’s own version of ruby and
dependencies installed.

On Tue, Dec 3, 2013 at 4:14 PM, Tim Dunphy bluethundr@gmail.com wrote:

how you have installed chef? may be GEM_PATH/GEM_HOME is messed up. do
you have multiple ruby installation ?

Hi and thanks for your response. I did a gem install. And I actually
didn’t have those variable set. So I tried setting them, and I did make a
little progress.

[root@chef:~] #echo $GEM_HOME
/usr/lib/ruby/vendor_ruby/1.8

[root@chef:~] #echo $GEM_PATH
/usr/lib/ruby/vendor_ruby/1.8/rubygems

But now I am getting a different error, so I may not have the correct
values there:

[root@chef:~] #knife configure --initial
/usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:247:in to_specs': Could not find chef (>= 0) amongst [] (Gem::LoadError) from /usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:256:into_spec’
from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1231:in `gem’
from /usr/local/bin/knife:1

Do you think you could point me in the right direction in setting these
variables? I think that might solve the problem.

Tim

On Tue, Dec 3, 2013 at 6:56 PM, Ranjib Dey dey.ranjib@gmail.com wrote:

how you have installed chef? may be GEM_PATH/GEM_HOME is messed up. do
you have multiple ruby installation ?

On Tue, Dec 3, 2013 at 3:52 PM, Tim Dunphy bluethundr@gmail.com wrote:

Hey all,

I’m attempting to configure chef client on my chef server and running
into an error.

[root@chef:~] #knife configure --initial
/usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:247:in to_specs': Could not find chef (>= 0) amongst [bunny-0.8.0, erubis-2.7.0, highline-1.6.15, ipaddress-0.8.0, json-1.7.5, mime-types-1.19, mixlib-authentication-1.3.0, mixlib-cli-1.3.0, mixlib-config-1.1.2, mixlib-log-1.4.1, mixlib-shellout-1.1.0, moneta-0.7.1, net-ssh-2.6.5, net-ssh-gateway-1.1.0, net-ssh-multi-1.1, ohai-6.14.0, polyglot-0.3.3, rest-client-1.6.7, systemu-2.5.2, treetop-1.4.12, uuidtools-2.1.3, yajl-ruby-1.1.0] (Gem::LoadError) from /usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:256:into_spec’
from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1231:in `gem’
from /usr/local/bin/knife:18

I am running chef 11.8.0 under ubuntu 13.10.

Can anyone provide some insight on how to get around this error?

Thanks!
Tim


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B


[ Julian C. Dunn jdunn@aquezada.com * Sorry, I’m ]
[ WWW: http://www.aquezada.com/staff/julian * only Web 1.0 ]
[ gopher://sdf.org/1/users/keymaker/ * compliant! ]
[ PGP: 91B3 7A9D 683C 7C16 715F 442C 6065 D533 FDC2 05B9 ]


#9

I would actually recommend rbenv or chruby over RVM. RVM is very
invasive, sets a bunch of environment variables that mess with Chef,
and you generally don’t need the overhead unless you’re a hardcore
Ruby developer working with multiple gemsets.

Sounds good. I think I’ll go this route. Thanks for the info and opinions
guys! All very valuable.

Best!
Tim

On Tue, Dec 3, 2013 at 11:53 PM, Julian C. Dunn jdunn@aquezada.com wrote:

I would actually recommend rbenv or chruby over RVM. RVM is very
invasive, sets a bunch of environment variables that mess with Chef,
and you generally don’t need the overhead unless you’re a hardcore
Ruby developer working with multiple gemsets.

  • Julian

On Tue, Dec 3, 2013 at 9:54 PM, Nikhil Shah nshah@theorchard.com wrote:

You can remove ruby all together and then install 1.9; however, if you
don’t
want to break anything, I would suggest using RVM (allows you to have
multiple ruby instances and set the running version). It’s nice bc you
can
switch easily and you can disable RVM and use the system default

Thanks,

Nikhil Shah

On Dec 3, 2013, at 9:07 PM, Tim Dunphy bluethundr@gmail.com wrote:

you also should not be using ruby 1.8 and should remove those packages
from your system and replace them with the ruby 1.9 ones.

Sounds like good advice. Could you perhaps recommend a safe way to
uninstall
ruby 1.8 without muffing up ruby 1.9?

Thanks
Tim

On Tue, Dec 3, 2013 at 7:22 PM, Booker Bense bbense@gmail.com wrote:

I’d strongly encourage you to try an omnibus install if at all possible.
It’s been a while since I tried it, but even Chef 10 did not work
smoothly

with ruby 1.8.

http://www.opscode.com/chef/install/

Your life will be much simpler if chef has it’s own version of ruby and
dependencies installed.

On Tue, Dec 3, 2013 at 4:14 PM, Tim Dunphy bluethundr@gmail.com
wrote:

how you have installed chef? may be GEM_PATH/GEM_HOME is messed up. do
you have multiple ruby installation ?

Hi and thanks for your response. I did a gem install. And I actually
didn’t have those variable set. So I tried setting them, and I did
make a

little progress.

[root@chef:~] #echo $GEM_HOME
/usr/lib/ruby/vendor_ruby/1.8

[root@chef:~] #echo $GEM_PATH
/usr/lib/ruby/vendor_ruby/1.8/rubygems

But now I am getting a different error, so I may not have the correct
values there:

[root@chef:~] #knife configure --initial
/usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:247:in `to_specs’:
Could not find chef (>= 0) amongst [] (Gem::LoadError)
from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:256:in

to_spec' from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1231:ingem’
from /usr/local/bin/knife:1

Do you think you could point me in the right direction in setting these
variables? I think that might solve the problem.

Tim

On Tue, Dec 3, 2013 at 6:56 PM, Ranjib Dey dey.ranjib@gmail.com
wrote:

how you have installed chef? may be GEM_PATH/GEM_HOME is messed up. do
you have multiple ruby installation ?

On Tue, Dec 3, 2013 at 3:52 PM, Tim Dunphy bluethundr@gmail.com
wrote:

Hey all,

I’m attempting to configure chef client on my chef server and running
into an error.

[root@chef:~] #knife configure --initial
/usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:247:in
`to_specs’:

Could not find chef (>= 0) amongst [bunny-0.8.0, erubis-2.7.0,
highline-1.6.15, ipaddress-0.8.0, json-1.7.5, mime-types-1.19,
mixlib-authentication-1.3.0, mixlib-cli-1.3.0, mixlib-config-1.1.2,
mixlib-log-1.4.1, mixlib-shellout-1.1.0, moneta-0.7.1, net-ssh-2.6.5,
net-ssh-gateway-1.1.0, net-ssh-multi-1.1, ohai-6.14.0,
polyglot-0.3.3,

rest-client-1.6.7, systemu-2.5.2, treetop-1.4.12, uuidtools-2.1.3,
yajl-ruby-1.1.0] (Gem::LoadError)
from
/usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:256:in to_spec' from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1231:ingem’
from /usr/local/bin/knife:18

I am running chef 11.8.0 under ubuntu 13.10.

Can anyone provide some insight on how to get around this error?

Thanks!
Tim


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B


[ Julian C. Dunn jdunn@aquezada.com * Sorry, I’m ]
[ WWW: http://www.aquezada.com/staff/julian * only Web 1.0 ]
[ gopher://sdf.org/1/users/keymaker/ * compliant! ]
[ PGP: 91B3 7A9D 683C 7C16 715F 442C 6065 D533 FDC2 05B9 ]


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B


#10

start with ‘dpkg -l | grep ruby’ and ‘dpkg -P’ all the ruby stuff you
find…

then, only if you need it for something, start with ‘apt-get install
ruby1.9.3’

i would skip rbenv or rvm entirely unless you really need them, setting
them up system-wide as root is generally more of a pain that its worth.

On 12/3/13 6:07 PM, Tim Dunphy wrote:

you also should not be using ruby 1.8 and should remove those
packages from your system and replace them with the ruby 1.9 ones.

Sounds like good advice. Could you perhaps recommend a safe way to
uninstall ruby 1.8 without muffing up ruby 1.9?

Thanks
Tim

On Tue, Dec 3, 2013 at 7:22 PM, Booker Bense <bbense@gmail.com
mailto:bbense@gmail.com> wrote:

I'd strongly encourage you to try an omnibus install if at all
possible. It's been a while since I tried it, but even Chef 10 did
not work smoothly with ruby 1.8.

http://www.opscode.com/chef/install/

Your life will be much simpler if chef has it's own version of
ruby and dependencies installed.


On Tue, Dec 3, 2013 at 4:14 PM, Tim Dunphy <bluethundr@gmail.com
<mailto:bluethundr@gmail.com>> wrote:

        how you have installed chef? may be GEM_PATH/GEM_HOME is
        messed up. do you have multiple ruby installation ?



    Hi and thanks for your response. I did a gem install. And I
    actually didn't have those variable set. So I tried setting
    them, and I did make a little progress.

    [root@chef:~] #echo $GEM_HOME
    /usr/lib/ruby/vendor_ruby/1.8

    [root@chef:~] #echo $GEM_PATH
    /usr/lib/ruby/vendor_ruby/1.8/rubygems

    But now I am getting a different error, so I may not have the
    correct values there:

    [root@chef:~] #knife configure --initial
    /usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:247:in
    `to_specs': Could not find chef (>= 0) amongst [] (Gem::LoadError)
            from
    /usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:256:in
    `to_spec'
            from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1231:in
    `gem'
            from /usr/local/bin/knife:1

    Do you think you could point me in the right direction in
    setting these variables? I think that might solve the problem.

    Tim


    On Tue, Dec 3, 2013 at 6:56 PM, Ranjib Dey
    <dey.ranjib@gmail.com <mailto:dey.ranjib@gmail.com>> wrote:

        how you have installed chef? may be GEM_PATH/GEM_HOME is
        messed up. do you have multiple ruby installation ?


        On Tue, Dec 3, 2013 at 3:52 PM, Tim Dunphy
        <bluethundr@gmail.com <mailto:bluethundr@gmail.com>> wrote:

            Hey all,

            I'm attempting to configure chef client on my chef
            server and running into an error.

            [root@chef:~] #knife configure --initial
            /usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:247:in
            `to_specs': Could not find chef (>= 0) amongst
            [bunny-0.8.0, erubis-2.7.0, highline-1.6.15,
            ipaddress-0.8.0, json-1.7.5, mime-types-1.19,
            mixlib-authentication-1.3.0, mixlib-cli-1.3.0,
            mixlib-config-1.1.2, mixlib-log-1.4.1,
            mixlib-shellout-1.1.0, moneta-0.7.1, net-ssh-2.6.5,
            net-ssh-gateway-1.1.0, net-ssh-multi-1.1, ohai-6.14.0,
            polyglot-0.3.3, rest-client-1.6.7, systemu-2.5.2,
            treetop-1.4.12, uuidtools-2.1.3, yajl-ruby-1.1.0]
            (Gem::LoadError)
                    from
            /usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:256:in
            `to_spec'
                    from
            /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1231:in `gem'
                    from /usr/local/bin/knife:18

            I am running chef 11.8.0 under ubuntu 13.10.

            Can anyone provide some insight on how to get around
            this error?

            Thanks!
            Tim

            -- 
            GPG me!!

            gpg --keyserver pool.sks-keyservers.net
            <http://pool.sks-keyservers.net> --recv-keys F186197B





    -- 
    GPG me!!

    gpg --keyserver pool.sks-keyservers.net
    <http://pool.sks-keyservers.net> --recv-keys F186197B


GPG me!!

gpg --keyserver pool.sks-keyservers.net
http://pool.sks-keyservers.net --recv-keys F186197B