Problem running chef client


#1

hi,

I am trying to deploy a war file on a node and hot this issue.

Net::HTTPServerException: 413 “Request Entity Too Large”
/opt/chef/embedded/lib/ruby/1.9.1/net/http.rb:2632:in `error!’

the recipe is very straight fwd copy the file from cookbook files folder
and then run a shell script.

Any ideas whats wrong

i tried to google it and added the ngnix.conf client_max_run 20M and
restarted the chef server but still the same issue .

Thanks
Manoj


#2

i tried to google it and added the ngnix.conf client_max_run 20M and
restarted the chef server but still the same issue .

the nginx config line should be:
client_max_body_size 20M;

On Mon, Sep 9, 2013 at 4:21 PM, Manoj Thakkar manoj.thakkar@gmail.comwrote:

hi,

I am trying to deploy a war file on a node and hot this issue.

Net::HTTPServerException: 413 “Request Entity Too Large”
/opt/chef/embedded/lib/ruby/1.9.1/net/http.rb:2632:in `error!’

the recipe is very straight fwd copy the file from cookbook files folder
and then run a shell script.

Any ideas whats wrong

i tried to google it and added the ngnix.conf client_max_run 20M and
restarted the chef server but still the same issue .

Thanks
Manoj


http://philcryer.com


#3

Ahh I typed it wrong in email but I set the same thing in my env. You mentioned below
I am not sure what the issue is

Sent from my iPhone

On Sep 9, 2013, at 5:37 PM, Phil Cryer phil@philcryer.com wrote:

i tried to google it and added the ngnix.conf client_max_run 20M and restarted the chef server but still the same issue .

the nginx config line should be:
client_max_body_size 20M;

On Mon, Sep 9, 2013 at 4:21 PM, Manoj Thakkar manoj.thakkar@gmail.com wrote:

hi,

I am trying to deploy a war file on a node and hot this issue.

Net::HTTPServerException: 413 “Request Entity Too Large”
/opt/chef/embedded/lib/ruby/1.9.1/net/http.rb:2632:in `error!’

the recipe is very straight fwd copy the file from cookbook files folder and then run a shell script.

Any ideas whats wrong

i tried to google it and added the ngnix.conf client_max_run 20M and restarted the chef server but still the same issue .

Thanks
Manoj


http://philcryer.com


#4

Then are you sure 20M is enough? How much are you pushing through? Maybe
try client_max_body_size 100M; and see if it works (not an ideal setting
obviously, but it might help debug)

On Mon, Sep 9, 2013 at 8:11 PM, Manoj manoj.thakkar@gmail.com wrote:

Ahh I typed it wrong in email but I set the same thing in my env. You
mentioned below
I am not sure what the issue is

Sent from my iPhone

On Sep 9, 2013, at 5:37 PM, Phil Cryer phil@philcryer.com wrote:

i tried to google it and added the ngnix.conf client_max_run 20M and
restarted the chef server but still the same issue .

the nginx config line should be:
client_max_body_size 20M;

On Mon, Sep 9, 2013 at 4:21 PM, Manoj Thakkar manoj.thakkar@gmail.comwrote:

hi,

I am trying to deploy a war file on a node and hot this issue.

Net::HTTPServerException: 413 “Request Entity Too Large”
/opt/chef/embedded/lib/ruby/1.9.1/net/http.rb:2632:in `error!’

the recipe is very straight fwd copy the file from cookbook files folder
and then run a shell script.

Any ideas whats wrong

i tried to google it and added the ngnix.conf client_max_run 20M and
restarted the chef server but still the same issue .

Thanks
Manoj


http://philcryer.com


http://philcryer.com