Problem with easy_install_package


#1

Hi Chefs,

I am running into trouble with the easy_install_package.

I want to install the “requests” module using the following resource
definition :
easy_install_package “requests” do
easy_install_binary "/usr/local/bin/easy_install-3.2"
provider Chef::Provider::package::EasyInstall
end

This resource will work if requests has NOT been installed for python2 even
if I specified the binary to use.
Manually running /usr/local/bin/easy_install-3.2 requests will work
though.

I have attached a sample recipe reproducing the problem.

Do you see what am I doing wrong ?


Dorian JAMINAIS
System Administrator
+33 6 95 10 95 37
http://perfect-memory.com

https://twitter.com/semanticbushttp://www.facebook.com/pages/Perfect-Memory/155555567821817