Problem with search


#1

Hi, Folks,

I have always had bad luck with knife search… it seems to omit some nodes
that should be listed. (I am running chef server 0.10.4)

Here I can see my apps1.auto.hulu.com node using knife command:

$ knife node show apps1.auto.hulu.com
Node Name: apps1.auto.hulu.com
Environment: automation
FQDN: apps1.auto.hulu.com
IP: 10.16.254.127
Run List: role[rjs-server]
Roles: hulu-common, rjs-server
Recipes: hulu-accounts, hulu-common, runit, rjs-server
Platform: centos 5.7

As you can see it has role[rjs-server] in the run list. But if I search for
it as follows, it does not return it.

$ knife search node "role:rjs-server"
1 items found

Node Name: apps2.auto.hulu.com
Environment: automation
FQDN:
IP:
Run List: role[rjs-server]
Roles:
Recipes:
Platform:

Am I missing something basic here?
Thanks,

-Steve


#2

OK… it seems that this has to do with the amount of node data being
uploaded to chef server.
I had a machine that was integrated to AD, and it was uploading about 500K
node data.
When I disabled passwd ohai plug in, by putting the following line to
/etc/chef/client.rb:

Ohai::Config[:disabled_plugins] = [“passwd”]

the node now seems to appear in my search result.

Is there some node data limit for search to work? If there is, is it
configurable?
Thanks,

-Steve

On Wed, Jan 11, 2012 at 7:29 PM, Steve Jang estebanjang@gmail.com wrote:

Hi, Folks,

I have always had bad luck with knife search… it seems to omit some
nodes that should be listed. (I am running chef server 0.10.4)

Here I can see my apps1.auto.hulu.com node using knife command:

$ knife node show apps1.auto.hulu.com
Node Name: apps1.auto.hulu.com
Environment: automation
FQDN: apps1.auto.hulu.com
IP: 10.16.254.127
Run List: role[rjs-server]
Roles: hulu-common, rjs-server
Recipes: hulu-accounts, hulu-common, runit, rjs-server
Platform: centos 5.7

As you can see it has role[rjs-server] in the run list. But if I search
for it as follows, it does not return it.

$ knife search node "role:rjs-server"
1 items found

Node Name: apps2.auto.hulu.com
Environment: automation
FQDN:
IP:
Run List: role[rjs-server]
Roles:
Recipes:
Platform:

Am I missing something basic here?
Thanks,

-Steve


#3

On Wednesday, January 11, 2012 at 8:17 PM, Steve Jang wrote:

OK… it seems that this has to do with the amount of node data being uploaded to chef server.
I had a machine that was integrated to AD, and it was uploading about 500K node data.
When I disabled passwd ohai plug in, by putting the following line to /etc/chef/client.rb:

Ohai::Config[:disabled_plugins] = [“passwd”]

the node now seems to appear in my search result.

Is there some node data limit for search to work? If there is, is it configurable?
You’ve run in to this:
http://tickets.opscode.com/browse/CHEF-2346

For us to fix it for everyone is tricky because of the way we distribute Solr, but it’s simple enough to fix yourself.


Dan DeLeo