Random easy_install errors


#1

Hi,

Why do I get totally random errors like this when use knife?

ec2-175-41-176-100.ap-southeast-1.compute.amazonaws.com [Sun, 15 Apr
2012 19:30:28 +0000] FATAL: Chef::Exceptions::package:
easy_install_package[pytz] (monitor_base::default line 99) had an
error: Chef::Exceptions::package: No version specified, and no
candidate version available for pytz


#2

You need to check on the relevant python list(s) whether the pypi servers
were having problems at these times. It’s been known to happen.

-Peter

On Sun, Apr 15, 2012 at 3:35 PM, David Montgomery <davidmontgomery@gmail.com

wrote:

Hi,

Why do I get totally random errors like this when use knife?

ec2-175-41-176-100.ap-southeast-1.compute.amazonaws.com [Sun, 15 Apr
2012 19:30:28 +0000] FATAL: Chef::Exceptions::package:
easy_install_package[pytz] (monitor_base::default line 99) had an
error: Chef::Exceptions::package: No version specified, and no
candidate version available for pytz