RE: rabbitmq-server will not start


#1

Turns out even though I disabled IPv6 via /etc/sysctl.conf per the recommendations in the CentOS FAQ, rabbitmq-server will still fail. so we had to add an entry into /etc/modprobe.conf.local as shown below.

  /etc/modprobe.conf.local

  install ipv6 /bin/true

All is well again.

Randy

From: Van Fossan,Randy
Sent: Monday, February 20, 2012 11:33 AM
To: chef@lists.opscode.com
Subject: rabbitmq-server will not start

I am having trouble on a new chef server… rabbitmq-server will not start (error logs below)… I using the chef-server cookbook with chef-solo to install chef server… It blows up during the startup of rabbitmq-server. I have disabled IPv6 in /etc/sysctl.conf. This is n CentOS 6.

I found some info in the rabbitmq forums, but nothing I have tried helps… Anyone else have this problem?

Thanks

Randy

---- Logs Below ------

cat /var/log/rabbitmq/startup_log

Activating RabbitMQ plugins …

0 plugins activated:

±–+ ±–+

| | | |

| | | |

| | | |

| ±–+ ±------+

| |

| RabbitMQ ±–+ |

| | | |

| v2.6.1 ±–+ |

| |

±------------------+

AMQP 0-9-1 / 0-9 / 0-8

Copyright © 2007-2011 VMware, Inc.

Licensed under the MPL. See http://www.rabbitmq.com/

node : rabbit@chefsy01rav

app descriptor : /usr/lib/rabbitmq/lib/rabbitmq_server-2.6.1/sbin/…/ebin/rabbit.app

home dir : /var/lib/rabbitmq

config file(s) : (none)

cookie hash : Wl9kb7MzIyg6Eedmia/PCg==

log : /var/log/rabbitmq/rabbit@chefsy01rav.log

sasl log : /var/log/rabbitmq/rabbit@chefsy01rav-sasl.log

database dir : /var/lib/rabbitmq/mnesia/rabbit@chefsy01rav

erlang version : 5.8.5

– rabbit boot start

starting file handle cache server …done

starting worker pool …done

starting database …done

starting codec correctness check …done

– external infrastructure ready

starting statistics event manager …done

starting logging server …done

starting plugin registry …done

starting auth mechanism amqplain …done

starting auth mechanism cr-demo …done

starting auth mechanism plain …done

starting exchange type direct …done

starting exchange type fanout …done

starting exchange type headers …done

starting exchange type topic …done

– kernel ready

starting node monitor …done

starting cluster delegate …done

starting guid generator …done

starting alarm handler …done

starting memory monitor …done

– core initialized

starting empty DB check …done

starting exchange, queue and binding recovery …done

starting mirror queue slave sup …done

starting adding mirrors to queues …done

– message delivery logic ready

starting error log relay …done

starting networking …BOOT ERROR: FAILED

Reason: {badmatch,

        {error,

            {shutdown,

                {child,undefined,'rabbit_tcp_listener_sup_:::5672',

                    {tcp_listener_sup,start_link,

                        [{0,0,0,0,0,0,0,0},

                         5672,

                         [inet6,binary,

                          {packet,raw},

                          {reuseaddr,true},

                          {backlog,128},

                          {nodelay,true},

                          {exit_on_close,false}],

                         {rabbit_networking,tcp_listener_started,[amqp]},

                         {rabbit_networking,tcp_listener_stopped,[amqp]},

                         {rabbit_networking,start_client,[]},

                         "TCP Listener"]},

                    transient,infinity,supervisor,

                    [tcp_listener_sup]}}}}

Stacktrace: [{rabbit_networking,start_listener0,4},

         {rabbit_networking,'-start_listener/4-lc$^0/1-0-',4},

         {rabbit_networking,start_listener,4},

         {rabbit_networking,'-boot_tcp/0-lc$^0/1-0-',1},

         {rabbit_networking,boot_tcp,0},

         {rabbit_networking,boot,0},

         {rabbit,'-run_boot_step/1-lc$^1/1-1-',1},

         {rabbit,run_boot_step,1}]

{“Kernel pid terminated”,application_controller,"{application_start_failure,rabbit,{bad_return,{{rabbit,start,[normal,[]]},{‘EXIT’,{rabbit,failure_during_boot}}}}}"}

cat /var/log/rabbitmq/startup_err

Erlang has closed

Crash dump was written to: erl_crash.dump

Kernel pid terminated (application_controller) ({application_start_failure,rabbit,{bad_return,{{rabbit,start,[normal,[]]},{‘EXIT’,{rabbit,failure_during_boot}}}}})