Re: Re: Re: Enabling bin-logging with mysql recipe


#1

Mike,

We have had similar issues and found that mysql isn’t picking up any over ride cnf files.

Our way around it is to use our own version of the mysql.cnf.erb in our recipe like so:

Override the existing MySQL my.cnf template as the default one doesn’t support replication

begin
t = resources(:template => “#{node[‘mysql’][‘conf_dir’]}/my.cnf”)
t.source “mysql_my.cnf.erb” t.cookbook "ninefold_app"
rescue Chef::Exceptions::ResourceNotFound
raise "Could not find template #{node[‘mysql’][‘conf_dir’]}/my.cnf to modify"
end

Hope this helps.

Regards,
Wazza

Warren Bain
http://ninefold.com
Australia’s cloud
direct: +61 2 8221 7729
mobile: +61 414 867 559
follow: http://twitter.com/thoughtcroft

Mathieu Martin webmat@gmail.com wrote:
Hey Mike,

Yes, chef restarted it properly. I’ve also tried restarting manually it as well…

Based on further investigation, the problem may have been caused by my setting innodb_log_file_size.

Changing this after a mysql database is initialized has a tendency to cause:

121213 12:31:16 [ERROR] Plugin ‘InnoDB’ init function returned error.
121213 12:31:16 [ERROR] Plugin ‘InnoDB’ registration as a STORAGE ENGINE
failed.
121213 12:31:16 [ERROR] Unknown/unsupported table type: InnoDB
121213 12:31:16 [ERROR] Aborting

I’ll try to investigate whether there’s a problem in the mysql cookbook with this setting when I get a moment, or if I was doing it wrong.

Anyhow, I’ve solved my problem for now.

Thanks,

Mat


#2

Warren,

It looks like you’re doing a bit of what Bryan Berry’s chef-rewind 0 does.

When you say that mysql isn’t picking up any override files, can you
elaborate on that? There’s a strict hierarchy MySQL uses to load
configuration files 1, and it’s typically “last one wins”.

Best,
-Mike

On Thu, Dec 13, 2012 at 3:36 PM, Warren Bain Warren@ninefold.com wrote:

Mike,

We have had similar issues and found that mysql isn’t picking up any over ride cnf files.

Our way around it is to use our own version of the mysql.cnf.erb in our recipe like so:

Override the existing MySQL my.cnf template as the default one doesn’t support replication

begin
t = resources(:template => “#{node[‘mysql’][‘conf_dir’]}/my.cnf”)
t.source “mysql_my.cnf.erb” t.cookbook "ninefold_app"
rescue Chef::Exceptions::ResourceNotFound
raise "Could not find template #{node[‘mysql’][‘conf_dir’]}/my.cnf to modify"
end

Hope this helps.

Regards,
Wazza

Warren Bain
http://ninefold.com
Australia’s cloud
direct: +61 2 8221 7729
mobile: +61 414 867 559
follow: http://twitter.com/thoughtcroft

Mathieu Martin webmat@gmail.com wrote:
Hey Mike,

Yes, chef restarted it properly. I’ve also tried restarting manually it as well…

Based on further investigation, the problem may have been caused by my setting innodb_log_file_size.

Changing this after a mysql database is initialized has a tendency to cause:

121213 12:31:16 [ERROR] Plugin ‘InnoDB’ init function returned error.
121213 12:31:16 [ERROR] Plugin ‘InnoDB’ registration as a STORAGE ENGINE
failed.
121213 12:31:16 [ERROR] Unknown/unsupported table type: InnoDB
121213 12:31:16 [ERROR] Aborting

I’ll try to investigate whether there’s a problem in the mysql cookbook with this setting when I get a moment, or if I was doing it wrong.

Anyhow, I’ve solved my problem for now.

Thanks,

Mat