Re: Re: Re: Re: Re: Re: Re: Re: Re: Problem running chef-client, just from 2 days ago


#1

Hello all,

I just fixed (Kind off) the problem.

Ill show you whats the error.

Is a failure in one of the rackspace images.

Both images are for Windows Server 2012.

This image has a problem and chef doesn’t work…
c50f70fc-79ec-4c71-bd4a-a4ac8f1641e1

This image works perfect.
715e6459-0330-4f36-89e7-19fb3cfe8620

This is the output while the server its being create from the workstation.
Check that there is an error while getting the chef client…

chef-client C:\Users\Administrator>goto install
chef-client Checking for existing downloaded package at
"C:\Users\ADMINI~1\AppData\Local\Temp\chef-client-latest.msi"
chef-client No existing downloaded packages to delete.
chef-client Attempting to download client package using cscript…
chef-client
chef-client C:\Users\Administrator>cscript /nologo C:\chef\wget.vbs
/url:“https://www.opscode.com/chef/download?p=windows&pv=2012&m=x86_64&v=
/path:“C:\Users\ADMINI~1\AppData\Local\Temp\chef-client-latest.msi”

chef-client CScript Error: Execution of the Windows Script Host
failed. (0x800A0007)
chef-client Failed cscript download with status code 1
chef-client Warning: Failed to download
"https://www.opscode.com/chef/download?p=windows&pv=2012&m=x86_64&v="
to “C:\Users\ADMINI~1\AppData\Local\Temp\chef-client-latest.msi"
chef-client Warning: Retrying download with PowerShell if available…
chef-client powershell.exe -ExecutionPolicy Unrestricted -NoProfile
-NonInteractive -File C:\chef\wget.ps1
"https://www.opscode.com/chef/download?p=windows&pv=2012&m=x86_64&v=&DownloadContext=PowerShell
"C:\Users\ADMINI~1\AppData\Local\Temp\chef-client-latest.msi"
chef-client Download via PowerShell succeeded.
chef-client Installing downloaded client package…

chef-client
chef-client C:\Users\Administrator>msiexec /qn /log
"C:\Users\ADMINI~1\AppData\Local\Temp\chef-client-msi4518.log" /i
"C:\Users\ADMINI~1\AppData\Local\Temp\chef-client-latest.msi"
chef-client Installation completed successfully
chef-client Writing validation key…
chef-client Validation key written.
chef-client
chef-client C:\Users\Administrator>mkdir C:\chef\ohai\hints
chef-client
chef-client C:\Users\Administrator>(echo.{}) 1>C:\chef\ohai\hints\rackspace.json
chef-client
chef-client C:\Users\Administrator>(
chef-client echo.log_level :info

Thanks for your help!!!

On Tue, May 27, 2014 at 11:54 AM, Carlos Camacho
carlos.camacho@frontiersin.org wrote:

Something really odd just happened.

I restarted the chef server and run the chef-client from Windows and
it worked fine… A few seconds later i executed the same command
again and i had the error… o.O

Check this out…

PS C:\Users\Administrator> chef-client
Starting Chef Client, version 11.12.4
[2014-05-27T09:43:31+00:00] INFO: *** Chef 11.12.4 ***
[2014-05-27T09:43:31+00:00] INFO: Chef-client pid: 3952
[2014-05-27T09:43:39+00:00] INFO: Run List is [role[windows]]
[2014-05-27T09:43:39+00:00] INFO: Run List expands to []
[2014-05-27T09:43:39+00:00] INFO: Starting Chef Run for slwnone10
[2014-05-27T09:43:39+00:00] INFO: Running start handlers
[2014-05-27T09:43:39+00:00] INFO: Start handlers complete.
[2014-05-27T09:43:39+00:00] INFO: HTTP Request Returned 404 Object Not Found:
resolving cookbooks for run list: []
[2014-05-27T09:43:39+00:00] INFO: Loading cookbooks []
Synchronizing Cookbooks:
Compiling Cookbooks…
Converging 0 resources
[2014-05-27T09:43:39+00:00] INFO: Chef Run complete in 0.561614 seconds

Running handlers:
[2014-05-27T09:43:39+00:00] INFO: Running report handlers
Running handlers complete
[2014-05-27T09:43:39+00:00] INFO: Report handlers complete
Chef Client finished, 0/0 resources updated in 11.029288 seconds

PS C:\Users\Administrator> chef-client
Starting Chef Client, version 11.12.4
[2014-05-27T09:43:51+00:00] INFO: *** Chef 11.12.4 ***
[2014-05-27T09:43:51+00:00] INFO: Chef-client pid: 3580
[2014-05-27T09:43:59+00:00] INFO: Run List is [role[windows]]
[2014-05-27T09:43:59+00:00] INFO: Run List expands to []
[2014-05-27T09:43:59+00:00] INFO: Starting Chef Run for slwnone10
[2014-05-27T09:43:59+00:00] INFO: Running start handlers
[2014-05-27T09:43:59+00:00] INFO: Start handlers complete.
[2014-05-27T09:43:59+00:00] INFO: HTTP Request Returned 404 Object Not Found:
resolving cookbooks for run list: []
[2014-05-27T09:43:59+00:00] INFO: Loading cookbooks []
Synchronizing Cookbooks:
Compiling Cookbooks…
Converging 0 resources

Running handlers:
[2014-05-27T09:43:59+00:00] ERROR: Running exception handlers
Running handlers complete
[2014-05-27T09:43:59+00:00] ERROR: Exception handlers complete
[2014-05-27T09:43:59+00:00] FATAL: Stacktrace dumped to
c:/chef/cache/chef-stacktrace.out
Chef Client failed. 0 resources updated in 10.670475 seconds
[2014-05-27T09:43:59+00:00] FATAL: EOFError: end of file reached

On Tue, May 27, 2014 at 10:54 AM, Carlos Camacho
carlos.camacho@frontiersin.org wrote:

Hello Lamont, Adam.

I’m finishing some tests and the PG error is documented here
(https://tickets.opscode.com/browse/CHEF-4390).

I have a new clue, so please if you can tell me what should be the
differences between these two types of connections.

If i connect the chef node (Windows) using pptpd and the server, it works fine.
If i connect the chef node (Windows) and the server using the
standard network, it fails.

Cheers!

On Wed, May 21, 2014 at 8:32 PM, Lamont Granquist lamont@opscode.com wrote:

The postgresql logs look interesting. The failed unique constraints might
be the problem. I would expect to see stack traces in the erchef logs
though.

On 5/20/14, 12:34 AM, Carlos Camacho wrote:

Hello,

Adam, Lamont good morning.

Ill give it a try to CHEF-5270 because this error is recent (I don’t
loose any trying as i’m stuck right now) about 2 weeks ago it suddenly
stop working. Also I’m attaching the chef-client logs in debug mode
and the chef-server logs. But again i don’t see any error in the
application layer.

Thanks for your help,

Cheers!

On Mon, May 19, 2014 at 9:15 PM, Lamont Granquist lamont@opscode.com
wrote:

On 5/19/14, 12:24 AM, Carlos Camacho wrote:

Hello Julian and Lamont,

I just check all logs in the server and there is not any apparent
error… It so confusing and frustrating this issue…

Well, the server is actually tearing down the connection normally with a
FIN|ACK, but then the client is still sending data, which produces a RST
from the server, then the client receives those and sends back FIN|ACK
and
RST of its own. So TCP is behaving normally and it does look like this
isn’t a rackspace issue. The question is why the server seems to tear
down
the connection early while the client is still attempting to send data.

There should be something either in the nginx or erchef logs on the
server
on in the -l debug logs or the stacktrace on the client.