Rest-client version


#1

I’m attempting to build Chef from the github opscode/chef repo master
branch. It is failing on ‘rake spec’ because of

Unable to activate chef-0.9.8, because rest-client-1.6.1 conflicts with
rest-client (<= 1.5.1, >= 1.0.4)

The related thing I can find in the issues is this,
http://tickets.opscode.com/browse/CHEF-1539, which says it set the required
rest-client to be <=1.7.0

Does anyone know what might be going on?

Tristan


#2

Ugh, nevermind. Sorry about that. For some reason it took me a bit to
realize its saying chef-0.9.8 and thus is grabbing the chef that was
installed earlier through gem install :slight_smile:

On Tue, Mar 22, 2011 at 11:21 AM, Tristan Sloughter <
tristan.sloughter@gmail.com> wrote:

I’m attempting to build Chef from the github opscode/chef repo master
branch. It is failing on ‘rake spec’ because of

Unable to activate chef-0.9.8, because rest-client-1.6.1 conflicts with
rest-client (<= 1.5.1, >= 1.0.4)

The related thing I can find in the issues is this,
http://tickets.opscode.com/browse/CHEF-1539, which says it set the
required rest-client to be <=1.7.0

Does anyone know what might be going on?

Tristan